Installing on Linux(CentOS 5.4)



  • hi,everybody,

    i want to install QT in linux(CentOS 5.4) using QtSdk-offline-linux-x86-v1.2.1.run
    with QT version(4.8.1) below:

    my gcc version is
    gcc version 4.1.2 20080704 (Red Hat 4.1.2-52)

    [root@tracvm qt_linux_sdk]# ./QtSdk-offline-linux-x86-v1.2.1.run
    ./QtSdk-offline-linux-x86-v1.2.1.run: /usr/lib/libstdc++.so.6: version GLIBCXX_3.4.11' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run) ./QtSdk-offline-linux-x86-v1.2.1.run: /lib/libc.so.6: versionGLIBC_2.9' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run)
    ./QtSdk-offline-linux-x86-v1.2.1.run: /lib/libc.so.6: version GLIBC_2.10' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run) ./QtSdk-offline-linux-x86-v1.2.1.run: /lib/libc.so.6: versionGLIBC_2.11' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run)
    ./QtSdk-offline-linux-x86-v1.2.1.run: /lib/libc.so.6: version `GLIBC_2.7' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run)

    but failed.

    i have tried other method as possible as others say below:
    [root@tracvm qt_linux_sdk]#ln -s /usr/lib/libstdc++.so.6.0.10 /usr/lib/libstdc++.so.6
    but it can not be installed .

    so please help me ,thanks


  • Moderators

    The library too old is not libstdc++ but glibc. Upgrading that will most likely require you to upgrade your complete linux system. If you can not do that, then you will need to rebuild Qt and the tools you need for your platform.

    Rebuilding is unfortunately only an option for the open-source parts (Qt, Qt creator, etc.) of the SDK.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.