Compiling Qt 5 on Red Hat Enterprise Linux 6.3 fails



  • Hi,

    I'm trying to compile Qt 5 on a RHEL 6.3 machine (Sources from Git repo, Machine is a VM if anyone cares)
    but it fails every single time at the QtQuick Modul. However, I found a bugreport which describes exactly the
    behavior I encounter:
    https://bugreports.qt-project.org/browse/QTBUG-25425
    and the follow up:
    https://bugreports.qt-project.org/browse/QTBUG-27114

    Problem is, bugreport is closed but current sources/configs don't seem to be fixed. I tried some things mentioned in the
    bugreport discussion but nothing worked:

    1. with or without -no-opengl option -> error is the same
    2. there is no -no-declarative option
    3. editing the linux.conf doesn't change a thing

    I don't need OpenGL support but WebKit is mandatory. Has somebody resolved this bug? Can someone explane to me how to compile Qt on my machine (simple words appreciated since I'm a non-regular linux user)

    btw. this is my configuration:
    configure -developer-build -opensource -confirm-license -no-gtkstyle -qt-xcb -nomake examples -nomake tests
    and as mentioned above -no-opengl doesn't change anything

    Thanks in advance
    JunkiXL


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.