Installing QT 5 for embedded system and some general questions.



  • Hello all,

    I am trying to get qt 5 up and running on my BeagleBone and after googling for a while am finding it all very confusing. When first researching about qt 5 I roughly compared it to .NET and thought I had at least the basic concept cleared up. But after reading more that "understanding" is no more. :) I was hoping to get some help on this forum. I would like to kindly ask for some help and will be very grateful to anyone willing to help me answer below questions:

    1. Is the basic concept of qt 5 similar to that of .NET ? Is it true what I read that QT will let you deploy desktop apps that don’t require the user to install a framework like .NET does?
    2. To get a working qt 5 application on my embedded system (BeagleBone) I need qt installed on the board (or not if the answer to above question about the need to install a framework is no) and on my development machine (in my case this is a Ubuntu 12.04 LTS PC). If I were to set up QT on my PC to develop and run PC applications (so like usually .NET in Windows) that installation could not be used for developing qt applications for embedded systems, is that correct?

    Now for the first step - installing qt 5 on my development environment (Ubuntu 12.04) according to:
    http://doc.qt.digia.com/qt/qt-embedded-install.html

    1. instructions on above page are for qt for embedded linux - qt 4.7. Why is there no qt 5 for embedded linux? Can normal qt 5 for linux also be used for embedded linux or must any patches be applied? I am especially concerned about X11 being needed. Is it common for embedded systems with linux and a small display to have X11?
    2. in the end I will be using arm (TI's am3359 processor on BeagleBone). Should I select -embedded generic or -embedded arm when running ./configure?
    3. When running make, which toolchain should be used? I used TI's toolchain from Arago project for building u-boot and linux kernel. But if I understand correctly this part of qt 5 build is only for my development environment (PC) so I shouldn't be using arago toolchain correct? Which one should I use?
    4. where do I set the toolchain? Should this be configured in ./configure or do I just add it to make as usual?
    5. the am3359 processor has an SGX graphics accelerator. How do I enable support for that in qt 5? (Patch perhaps?) Must I do that already when setting up my development environment or only when installing qt 5 on my target device (am3359 on Beaglebone) ?

    This should be enough for now. It will enough to process. :)

    A big thank you in advance to anyone answering any of above questions.

    Cheers!

    P.s.: I was not sure where to put this topic. General and Desktop, Mobile and Embedded and this forum all seemed like viable choices. I trust the topic will be moved if I chose wrong.



  • Nobody? Anybody?

    Perhaps I can shorten my above post by first asking only the following:
    In QT 4.8 there was a QT for Embedded Linux and QT for Linux/X11. No such distinction exists in QT 5. As I understand it the difference between mentioned QT 4.8 versions is that one is built on top of X11 and the other implements its own Window system, the QWS (QT Window Server which works directly with the framebuffer).
    Is my understanding described above correct and if so, where did QT 5 for Embedded Linux go? How does one install QT 5 for embedded Linux?

    Thanks.



  • Lets have one place to continue the discussion,

    http://e2e.ti.com/support/dsp/sitara_arm174_microprocessors/f/791/p/238994/837724.aspx#837724

    Its generally easier to track this way.



  • Hi,
    Any solution with that?
    I was spend the last week trying to install QT5 sdk in Beagleboard and Pandaboard(I have both), and no way.
    If anybody found the solution please through me a rope.
    Thanks.



  • Can you please explain what you have tried, and what did not work ?

    bq. >> I was spend the last week trying to install QT5 sdk in Beagleboard and Pandaboard(I have both), and no way.



  • prabindh:
    Thank's for reply.
    My environment IMac, Macbook pro.
    BBxM:
    I get de demo from http://downloads.angstrom-distribution.org/demo/beagleboard/
    Expand it and make a disk image via dd command.
    Already plugged and booted opkg update
    opkg install qt4-x11-free
    opkg install qmake2
    opkg remove --force-depend libgcc-s-dev
    opkg install qt4-x11-free-dev
    opkg install qt4-x11-free-doc
    opkg install task-native-sdk
    source /usr/share/qt4/enviroment-setup
    Create a simple Hello Word -> qmake2 -> make
    Compile and run OK.
    Problems:
    -I don't find how to do that with qt5.
    -Video performance is very, very bad.

    Pandaboard RevC:
    get de Ubuntu server 10.04 image from http://Texas Instruments OMAP4 (Hard-Float) preinstalled server image
    Expand it and make a disk image via dd command.
    Already plugged and booted:
    ~sudo apt-get update
    ~sudo apt-get upgrade
    ~sudo apt-get clean
    ~sudo reboot
    ~sudo apt-get install openssh-server
    ~sudo apt-add-repository ppa:tiomap-dev/release
    ~sudo apt-get update
    ~sudo apt-get dist-upgrade --yes
    ~apt-get install ubuntu-omap4-extras u-boot-tools --yes --force-yes
    ~sudo apt-get install --reinstall pvr-omap4-dkms
    ~sudo nano /boot/boot.script
    Edit “mem=1G@0×80000000”
    ~sudo flash-kernel --update-bootloader
    ~sudo reboot
    ~sudo nano /etc/fstab
    Comment the last line #/SWAP.swap none swap sw 0 0
    From here connect via ssh
    ~sudo apt-get install ubuntu-restricted-extras
    Way1
    ~$ sudo apt-add-repository ppa:ubuntu-sdk-team/ppa
    ~sudo apt-get update
    ~sudo apt-get autoremove
    ~sudo apt-get clean
    ~sudo flash-kernel --update-bootloader
    ~sudo reboot
    Way2
    /usr/bin/alsaucm -c PandaES set _verb HiFi
    sudo /usr/sbin/flash-kernel --update-bootloader
    sudo apt-get install build-essential git pkg-config libqt4-dev qt4-qmake
    sudo apt-get install libicu48
    sudo apt-get autoremove
    sudo apt-get install --reinstall ubuntu-omap4-extras u-boot-tools --yes --force-yes
    sudo flash-kernel --update-bootloader
    sudo reboot
    Results:
    Way1 Video player stop working, show a black screen, qtCreator does'n work, empty windows.
    Way2 don't compile, because don't found dependencies(I think), I don't find environments-setup.

    Described above is an excerpt, actually I spend days writing, like a monkey a lot of commands many times without know what I was doing.
    I'm started from scratch at least four times each day, I'm an experienced programmer but installations make me crazy.
    Thanks for your time and apologize my poor english.



  • The Beagle does not have a DRM sgx driver yet. But on Pandaboard, have you tried working with the details provided in the post below ?

    http://tigraphics.blogspot.in/2013/08/qt5-with-kms-omap5-jacinto6.html

    If working with a no opengl, or no display option is acceptable for your development purpose for now, you can use the instructions for building Qt5 for Beaglebone at,

    http://gpupowered.org/node/20



  • prabindh:
    Thank’s for your help.
    I read the post you recommend, interesting but the TI GLSDK 6.01.00.01 with prebuilt Qt5 binaries is for OMAP5, and I can't find the equivalent for OMAP4.
    Thanks one more time.



  • The steps for building Qt5 with KMS support (provided in the page) are the same across any system. If you have a root filesystem with the KMS headers and libraries installed, and the corresponding toolchains, that is enough to build Qt5.



  • Hi. In my case I use Raspberry PI with Qt and freepascal. I'm not sure Raspberry PI is similar to BeagleBone.
    Normally I write the application with my pc and then, with an emulated machine (using QEmu) I compile my program for arm.
    In order to compile Qt on QEmu you have to download the Qt source, delete the webkit directory and then with ./configure make make install you have Qt on arm.



  • prabindh:
    Thank for the answer, I will try.
    As I say before my environment is MAC, and I 'm avoiding install Ubuntu in a virtual machine until now because I have a bad experience with Virtualbox in the past. That's the reason I'm looking for a precompiled image with QT5 or a package I can install in the target via package manager.
    But if the only way is do by my self in the host, I will install Virtualbox, Ubuntu, and the SDK in order to generate the image with QT5 included.
    Thank one more time.

    mrdebug:
    I don't know the differences between Raspberry PI an Pandaboard, I will take in consideration your comments.
    Thank for your answer.

    I afraid next weekend will be a nightmare.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.