[Solved] Lubuntu 12.10 - Package X11 not found - Qt5



  • I'm trying to compile Qt5 on Lubuntu Linux 12.10

    After a while i'm getting the following error:

    make[2]: Map '/home/grove/qt5/qtwebkit/Source/WebCore' wordt binnengegaan
    ( test -f Makefile.WebCore.DerivedSources || /home/grove/qt5/qtbase/bin/qmake /home/grove/qt5/qtwebkit/Source/WebCore/DerivedSources.pri -o Makefile.WebCore.DerivedSources ) && make -f Makefile.WebCore.DerivedSources
    make[3]: Map '/home/grove/qt5/qtwebkit/Source/WebCore' wordt binnengegaan
    make[3]: Er hoeft niets gedaan te worden voor 'first'.
    make[3]: Map '/home/grove/qt5/qtwebkit/Source/WebCore' wordt verlaten
    ( test -f Makefile.WebCore.Target || /home/grove/qt5/qtbase/bin/qmake /home/grove/qt5/qtwebkit/Source/WebCore/Target.pri -o Makefile.WebCore.Target ) && make -f Makefile.WebCore.Target
    make[3]: Map '/home/grove/qt5/qtwebkit/Source/WebCore' wordt binnengegaan
    make[3]: Er hoeft niets gedaan te worden voor 'first'.
    make[3]: Map '/home/grove/qt5/qtwebkit/Source/WebCore' wordt verlaten
    make[2]: Map '/home/grove/qt5/qtwebkit/Source/WebCore' wordt verlaten
    cd Source/WebKit/ && ( test -f Makefile.WebKit1 || /home/grove/qt5/qtbase/bin/qmake /home/grove/qt5/qtwebkit/Source/WebKit/WebKit1.pro -o Makefile.WebKit1 ) && make -f Makefile.WebKit1
    Project ERROR: Package x11 not found
    make[1]: *** [sub-Source-WebKit-WebKit1-pro-make_first-ordered] Fout 3
    make[1]: Map '/home/grove/qt5/qtwebkit' wordt verlaten
    make: *** [module-qtwebkit-make_first] Fout 2

    Can anybody help me with this??



  • Having the same issue and libx11-dev is already installed.
    Any idea?

    (I'm on kubuntu)


  • Moderators

    If you don't, by any chance, use webkit, you can just remove that directory and compile without it. This is not a real solution, though, I know. I've hit this once, too, but sadly I don't remember the solution.



  • Hi Redkite,

    om my desktop with kubuntu I've installed qt5 with no problems following the noted of:
    "Qt5 from git":http://qt-project.org/wiki/Building_Qt_5_from_Git



  • sierdzio> No luck, I need WebKit and OpenSSL :-(
    grove825> I tried to install all dependencies found there, and I still get the same error.

    Trying again from new sources (fresh extract of tar.gz)



  • Really slow in my VM ><

    I have installed all dependencies listed in http://qt-project.org/wiki/Building_Qt_5_from_Git.
    But still the same problem :

    @...tml/HTMLElementsAllInOne.o .obj/debug-shared/editing/EditingAllInOne.o .obj/debug-shared/rendering/RenderingAllInOne.o .obj/debug-shared/.moc/debug-shared/moc_QtMIMETypeSniffer.o
    rm -f debug/libWebCore.a
    mv -f libWebCore.a debug/
    make[3]: Leaving directory /home/gauthier/Devel/5.0.0/qtwebkit/Source/WebCore' make[2]: Leaving directory/home/gauthier/Devel/5.0.0/qtwebkit/Source/WebCore'
    cd Source/WebKit/ && ( test -f Makefile.WebKit1 || /home/gauthier/Devel/5.0.0/qtbase/bin/qmake /home/gauthier/Devel/5.0.0/qtwebkit/Source/WebKit/WebKit1.pro -o Makefile.WebKit1 ) && make -f Makefile.WebKit1
    Project ERROR: Package x11 not found
    make[1]: *** [sub-Source-WebKit-WebKit1-pro-make_first-ordered] Error 3
    make[1]: Leaving directory `/home/gauthier/Devel/5.0.0/qtwebkit'
    make: *** [module-qtwebkit-make_first] Error 2
    @

    Update: Fresh new VM with kubuntu 12.10, and here is what I did for still getting the same result than previously (building in release for trying to accelerate the build) :

    @cd
    mkdir Devel
    cd Downloads
    wget http://releases.qt-project.org/qt5/5.0.0/single/qt-everywhere-opensource-src-5.0.0.tar.gz
    tar zxvf qt-everywhere-opensource-src-5.0.0.tar.gz

    cd ../Devel/5.0.0

    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install build-essential libx11-dev perl python libssl-dev libmysqlclient-dev libxext-dev libxrender-dev flex bison gperf
    sudo apt-get install libxcb1 libxcb1-dev libx11-xcb1 libx11-xcb-dev libxcb-keysyms1 libxcb-keysyms1-dev libxcb-image0 libxcb-image0-dev libxcb-shm0 libxcb-shm0-dev libxcb-icccm4 libxcb-icccm4-dev libxcb-sync0 libxcb-sync0-dev libxcb-xfixes0-dev libxrender-dev libxcb-shape0-dev libxcb-randr0-dev libxcb-render-util0 libxcb-render-util0-dev libxcb-glx0-dev
    sudo apt-get install libicu-dev
    sudo apt-get install libgl1-mesa-dev libgles2-mesa-dev mesa-utils

    ./configure -release -opensource -confirm-license -fast -nomake examples -nomake demos -nomake tests -qt-sql-mysql -openssl
    make
    @



  • Compile block on :
    @$ /home/tadaweb/Devel/5.0.0/qtbase/bin/qmake /home/tadaweb/Devel/5.0.0/qtwebkit/Source/WebKit/WebKit1.pro -o Makefile.WebKit1
    Project ERROR: Package x11 not found@

    I commented in 5.0.0/qtwebkit/Source/WebKit/WebKit1.pri this suspect line :
    @#use?(PLUGIN_BACKEND_XLIB): PKGCONFIG += x11@

    Same in 5.0.0/qtwebkit/Source/WebKit2/Target.pri
    @use?(PLUGIN_BACKEND_XLIB) {
    DEFINES += XP_UNIX

    PKGCONFIG += x11

    DEFINES += MOZ_X11
    

    }@

    Same in 5.0.0/qtwebkit/Source/widgetsapi.pri
    @#use?(PLUGIN_BACKEND_XLIB): PKGCONFIG += x11@

    I comment it and now, the build continue flawlessly :-(
    I just built a application with a mainwindow and a QWebView using https and it's running.



  • Thx redkite.

    I'll try this as soon as I can.



  • Thanks again redkit.

    Now running without any problems.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.