[Solved] Setup debugging for mini2440 using Qt Creator and GDB/GDBServer



  • Hi everyone

    I'm not sure if this is the right forum to post this, if its not I appologise. I have a bit of an issue setting up GDB debugging for a mini2440 using the Qt Creator IDE. My distro is Ubuntu 12.04 and I cant seem to find any examples. Also, I'm using Pengutronix BSP.

    I would like some guidance or "how to" steps or something to enable me to debug the mini2440.

    If there is anyone that can help me, I'd really appreciate it.

    thanks

    Ruben


  • Moderators

    You will need to have ssh and gdbserver installed on your board for this to work. Then you need to "set up your board":http://qt-project.org/doc/qtcreator-2.6/creator-developing-generic-linux.html in Creator. Afterwards you need to "set up a kit":http://qt-project.org/doc/qtcreator-2.6/creator-targets.html using this device.

    Then everything should just work:-)



  • Hi Tobias

    Thank you for your reply. just a few questions I'm not ure about, if you dont mind:

    1. is it mandatory to use ssh for the connection, or may I omit ssh?
    2. I'm using ptxdist to build a bsp for my device, it only supports openssh, will it be ok if I use openssh instead?

    thanks in advance

    Ruben


  • Moderators

    SSH is the most widely used way to connect to linux machines nowadays (because it is secure) and that is why we support that. Creator does support other methods as well, but those are for special devices (IIRC android does use something different, as does QNX), but since your device is most likely running neither android nor QNX those do not apply here. Other options could be added of course, but that would require some coding work in Creator and I am not sure you are willing to do that;-)

    Any implementation of the SSH protocol is fine. OpenSSH works, as does e.g. dropbear.



  • Hi Tobias

    Thank you for your help. I'm a newbie concerning this, so please bare with me. I followed the first page (you supplied above) step by step, but when I want to build my project, I get the following errors:

    1. :-1: warning: libts-0.0.so.0, needed by /home/orbit/OSELAS.BSP-Pengutronix-Mini2440-2012.12.0/platform-mini2440/sysroot-target/usr/lib/libQtGui.so, not found (try using -rpath or -rpath-link)
    2. :-1: warning: libpng12.so.0, needed by /home/orbit/OSELAS.BSP-Pengutronix-Mini2440-2012.12.0/platform-mini2440/sysroot-target/usr/lib/libQtGui.so, not found (try using -rpath or -rpath-link)
    3. :-1: warning: libz.so.1, needed by /home/orbit/OSELAS.BSP-Pengutronix-Mini2440-2012.12.0/platform-mini2440/sysroot-target/usr/lib/libQtGui.so, not found (try using -rpath or -rpath-link)
      4.:-1: warning: libfreetype.so.6, needed by /home/orbit/OSELAS.BSP-Pengutronix-Mini2440-2012.12.0/platform-mini2440/sysroot-target/usr/lib/libQtGui.so, not found (try using -rpath or -rpath-link)

    When I navigate to the folder, I can see these files there. Not really sure why its complaining.

    I feel a bit lost with this one and appreciate your help.

    Thank you.

    Ruben



  • I should also mention that I downloaded Qt Creator 2.6.1 as the one in Software Center was 2.4.1.



  • I got this to work, how do I close my ticket?


  • Moderators

    Which ticket?

    Just put "[Solved]" in front of the title by editing the original post if you want to mark this posting as done.



  • thanks Tobias


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.