Qt Creator - pkgconfig problem



  • Hi everyone,

    I have a problem with Qt Creator not seeing include files when using pkgconfig. Everything builds and runs fine, but the text editor does not see the include files and hence does not autocomplete.

    My setup is:

    Linux 3.6.10-1-ARCH #1 SMP PREEMPT Tue Dec 11 09:40:17 CET 2012 x86_64 GNU/Linux

    Qt Creator 2.6.1
    Based on Qt 4.8.4 (64 bit)

    Example:

    gst.pro
    @QT += core gui

    greaterThan(QT_MAJOR_VERSION, 4): QT += widgets

    TARGET = gst
    TEMPLATE = app

    SOURCES += main.cpp
    widget.cpp

    HEADERS += widget.h

    unix:!macx {

    INCLUDEPATH += /usr/include/gstreamer-0.10

    CONFIG += link_pkgconfig
    PKGCONFIG += gstreamer-interfaces-0.10
    

    }@

    main.cpp
    @#include "widget.h"
    #include <QApplication>

    int main(int argc, char *argv[])
    {
    QApplication a(argc, argv);
    Widget w;
    w.show();

    return a.exec&#40;&#41;;
    

    }@

    widget.h
    @#ifndef WIDGET_H
    #define WIDGET_H

    #include <gst/gst.h>
    #include <gst/interfaces/xoverlay.h>
    #include <QWidget>

    class Widget : public QWidget
    {
    Q_OBJECT

    public:
    explicit Widget(QWidget *parent = 0);
    ~Widget();

    private:
    GstElement *m_pipeline;
    GstElement *m_src;
    GstElement *m_sink;
    };

    #endif // WIDGET_H@

    widget.cpp
    @#include "widget.h"

    Widget::Widget(QWidget *parent) :
    QWidget(parent)
    {
    gst_init(NULL, NULL);

    m_pipeline = gst_pipeline_new("pipeline");
    m_src = gst_element_factory_make("videotestsrc", "src");
    m_sink = gst_element_factory_make ("xvimagesink", "vSink");
    
    gst_bin_add_many(GST_BIN(m_pipeline), m_src, m_sink, NULL);
    gst_element_link_many(m_src, m_sink, NULL);
    
    gst_x_overlay_set_xwindow_id(GST_X_OVERLAY(m_sink), this->winId());
    
    gst_element_set_state (m_pipeline, GST_STATE_PLAYING);
    

    }

    Widget::~Widget()
    {
    gst_object_unref(m_pipeline);
    }@

    Sorry for the long post. I don't know if this is a correct place to ask.
    I welcome any suggestions.

    Thanks,
    horho77


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.