Problem opening a .pro file in Qt creator: Program stops responding

  • Hello,
    I am trying to get the Tiled Map Editor source (downloaded here: to open in Qt Creator on Windows7 SP1 64-bit. The problem I have is that after attempting to open the root project (by either double clicking the .pro file or doing a File->Open in the App itself) Qt Creator stops responding and just hangs. I have left it as long as 6 minutes with no response.

    I did some experimenting and found that the problem seems to be related to the src/ file referencing the src/tiled/ file.

    For reference I have inlined the src/ contents:
    TEMPLATE = subdirs
    CONFIG += ordered

    SUBDIRS = libtiled tiled plugins

    I can load src/tiled/ alone perfectly fine, with no noticeable delay.
    But loading src/ alone has the same problem as, the application hangs indefinitely and stops responding.

    As an experiment, I tried removing "tiled" from the SUBDIRS list in The problem went away, but of course, the tiled project was not loaded.
    I also tried removing everything from SUBDIRS except tiled, and the problem remained.

    Has anyone else run into this or a similar issue and/or found a solution?

    I have started a similar thread on the Tiled mailing list:!topic/mapeditor/QvnGKVT95x8

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.