Can't run Qt5 Launch Demo on OSX Mountain Lion



  • I've installed the Qt5 binaries for OSX and cloned the Qt5 launch demo using git. I'm able to create a new QtQuick 2.0 project in creator and run it. However, when I load the Qt5 launch demo project in creator, and run it with QMLViewer, I get

    @Starting /Users/tshead/Qt5.0.0/5.0.0/clang_64/bin/QMLViewer.app/Contents/MacOS/QMLViewer /Users/tshead/src/qt5-launch-demo/main.qml
    Qml debugging is enabled. Only use this in a safe environment!
    file:///Users/tshead/src/qt5-launch-demo/main.qml:41:1: Type DemoMain unavailable
    DemoMain {
    ^
    file:///Users/tshead/src/qt5-launch-demo/DemoMain.qml:42:1: module "QtQuick" version 2.0 is not installed
    import QtQuick 2.0
    ^ @

    and an empty window. If I run it with QMLScene, I get

    @Starting /Users/tshead/Qt5.0.0/5.0.0/clang_64/bin/qmlscene /Users/tshead/src/qt5-launch-demo/main.qml
    file:///Users/tshead/src/qt5-launch-demo/main.qml:41 Type DemoMain unavailable
    file:///Users/tshead/src/qt5-launch-demo/DemoMain.qml:121 Type SlideDeck unavailable
    file:///Users/tshead/src/qt5-launch-demo/SlideDeck.qml:45 module "Qt.labs.presentation" is not installed

    /Users/tshead/Qt5.0.0/5.0.0/clang_64/bin/qmlscene exited with code 255@

    and no window at all. I assume this is a configuration issue somewhere, but am new to QML. Any suggestions?

    Many thanks,
    Tim


  • Moderators

    QMLViewer is for QtQuick1, IIRC. Please read the README in the Launch Demo - it asks to use qmlscene + presentation system.



  • Hi Tim,

    I had a very similar issue when trying to run qt5 launch demo with qmlscene. Try downloading the source code of qml presentation (git clone https://git.gitorious.org/qt-labs/qml-presentation-system.git ), then go to the qml-presentation-system directory and type make install. This solved my problem :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.