Odd behaviour on Ubuntu



  • Hi All,

    I'm having a very strange behaviour building a release executable file on ubuntu. The problem: I made the executable file using the make button ("the hammer") on Qt, the executable file has been created and if I launch it using the run button by Qt it seems to work properly but, when I go to the folder where it was created and I try to launch it double clicking on its icon it doesn't start. Nothing happen! Does anyone know why?

    Note: I have got the admin privileges on the PC.



  • Is the file permissions set to executional rights?

    You can set the execute permission as: chmod +x /path/filetoexecute



  • I did it. I've launched the app, writing on the terminal the name of the executable starting from the path of the executable file after I'd done what you've suggested doing and the result was nothing. The app wasn't launched! I also tried to launch the app by double clicking on its icon and I got the same result.

    This problem starts to make me crazy!!!!



  • Do you have in your path the Qt libraries included? If not, in your console try: (suppose your Qt libraries .a and .so are in /usr/Qt/4.8.4/lib)

    @export LD_LIBRARY_PATH=/usr/Qt/4.8.4/lib:$LD_LIBRARY_PATH@

    After that try to execute (from console). Does it work?



  • It doesn't work...
    The answer from the terminal is <name of executable>: command not found.



  • The strange is that I can run from the terminal the all other apps, it seems that the only apps I can't run from the terminal are the Qt creator and the apps builds from Qt....



  • What command do you use to execute the program?
    It must be
    @./yourbinaryfile@
    Note the "./" indicating the current working directory. If you just want to be able to enter the name of the binary, like a bash command, you must move your binary to one of the "bin" directories, or at least make a softlink there.



  • Have you executed it with

    @./<Name of Executable>@

    ? That's the type of answer you get from the terminal when you don't include the ./



  • Ok...
    Now it seems to work, I just forget the to use the ./ ; I'm sorry but I'm new on ubuntu os.

    Thank you very much for your support.
    Have a nice Christmas time!!!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.