Qt Creator project wizard does not display option to create a Qt project



  • I have the latest version of MinGW installed, along with the Qt 4.8.4 SDK and Qt Creator. I am running an x64 Windows 7 machine. While installing the Qt SDK, this error did come up:

    There is a problem with your MinGW installation:
    The installer could not find a valid C:\MinGW\include\w32api.h
    (The supported version is 3.2)
    Do you still want to continue? (Your installation may not work)

    But according to "this ":http://www.qtcentre.org/archive/index.php/t-14862.html thread, it should not have been a problem. Unfortunately, I have no idea how to actually set up Qt so that it will allow me to use the Application project wizard. I have attached a screenshot of my template selection, and "here ":http://harmattan-dev.nokia.com/docs/library/html/guide/figures/Qt_SDK_NewProject.png is what I think it should look like.
    !http://i.stack.imgur.com/9LcAA.png()!

    I should note that I just used the executeable version of Qt, as it seems you need Visual Studio to compile the Qt source, and I only have the "express" version of VS, and it has given me nothing but grief.


  • Moderators

    I think Qt 4.8.4 is not part of any SDK right now, so I assume you are installing Qt Creator and Qt 4.8.4 next to each other in independent steps.

    If that is the case then Qt Creator most likely does not know you have Qt installed. Without Qt it will not offer to set up Qt projects. Go to Tools>Options>Build & Run>Qt versions and make sure your Qt is registered there. Go to Tools>Options>Build & Run>Kits (if you are using version 2.6 or later;-) and make sure the Kits are actually using that Qt version. Afterwards you should be set to go.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.