EXC_CRASH (SIGABRT) error



  • Hello All,

    I've been searching around in the forum but so far haven't found probably similar problem with my case. Apologize if there is one.

    I have a qt desktop application and am now trying to build it as a package. After building it, I made a copy of all its libraries in the application bundle and modified the links to them. This was done by the command install_name_tool.

    When I checked with otool -L command, here is the output :

        executable_path/../Frameworks/QtWebKit.framework/Versions/4/QtWebKit (compatibility version 4.9.0, current version 4.9.0)
    

    executable_path/../Frameworks/QtGui.framework/Versions/4/QtGui (compatibility version 4.8.0, current version 4.8.1)
    executable_path/../Frameworks/QtCore.framework/Versions/4/QtCore (compatibility version 4.8.0, current version 4.8.1)
    /usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.9.0)
    /usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 830.0.0)
    /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11)

    Rest assured that the links looks fine, I run the executable file and found out that it exited unexpectedly leaving the error log as follow :
    (Note : the application was built using Qt creator 2.4.1 based on Qt 4.7.4 (64 bit) )

    @Process: varb [33826]
    Path: /Users/hidayal/gitrepos/VarB/varb.app/Contents/MacOS/varb
    Identifier: com.yourcompany.varb
    Version: ??? (???)
    Code Type: X86-64 (Native)
    Parent Process: launchd [325]

    Date/Time: 2012-12-17 10:41:58.999 +0300
    OS Version: Mac OS X 10.6.8 (10K549)
    Report Version: 6

    Interval Since Last Report: 4461425 sec
    Crashes Since Last Report: 130
    Per-App Interval Since Last Report: 1269610 sec
    Per-App Crashes Since Last Report: 85
    Anonymous UUID: 5B885CB6-2F9A-4BCE-819F-F17EBC2D2A25

    Exception Type: EXC_CRASH (SIGABRT)
    Exception Codes: 0x0000000000000000, 0x0000000000000000
    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Application Specific Information:
    abort() called

    Thread 0 Crashed: Dispatch queue: com.apple.main-thread
    0 libSystem.B.dylib 0x00007fff891a60b6 __kill + 10
    1 libSystem.B.dylib 0x00007fff892469f6 abort + 83
    2 QtCore 0x0000000103f908d5 qt_message_output(QtMsgType, char const*) + 117
    3 QtCore 0x0000000103f90ab7 qt_message(QtMsgType, char const*, __va_list_tag*) + 183
    4 QtCore 0x0000000103f90c7a qFatal(char const*, ...) + 170
    5 QtGui 0x000000010335b245 QWidgetPrivate::QWidgetPrivate(int) + 853
    6 QtGui 0x000000010336f8fb QWidget::QWidget(QWidget*, QFlagsQt::WindowType) + 59
    7 QtWebKit 0x00000001006ccf6e QWebView::QWebView(QWidget*) + 30
    8 com.yourcompany.varb 0x00000001000113e3 Ui_MainWindow::setupUi(QMainWindow*) + 10035 (ui_mainwindow.h:514)
    9 com.yourcompany.varb 0x000000010000404a MainWindow::MainWindow(QWidget*) + 186 (mainwindow.cpp:40)
    10 com.yourcompany.varb 0x000000010000346c main + 76 (qwidget.h:494)
    11 com.yourcompany.varb 0x00000001000033f8 start + 52

    Thread 1: Dispatch queue: com.apple.libdispatch-manager
    0 libSystem.B.dylib 0x00007fff89170c0a kevent + 10
    1 libSystem.B.dylib 0x00007fff89172add _dispatch_mgr_invoke + 154
    2 libSystem.B.dylib 0x00007fff891727b4 _dispatch_queue_invoke + 185
    3 libSystem.B.dylib 0x00007fff891722de _dispatch_worker_thread2 + 252
    4 libSystem.B.dylib 0x00007fff89171c08 _pthread_wqthread + 353
    5 libSystem.B.dylib 0x00007fff89171aa5 start_wqthread + 13

    Thread 2:
    0 libSystem.B.dylib 0x00007fff89171a2a __workq_kernreturn + 10
    1 libSystem.B.dylib 0x00007fff89171e3c _pthread_wqthread + 917
    2 libSystem.B.dylib 0x00007fff89171aa5 start_wqthread + 13

    Thread 0 crashed with X86 Thread State (64-bit):
    rax: 0x0000000000000000 rbx: 0x0000000000000000 rcx: 0x00007fff5fbfeb88 rdx: 0x0000000000000000
    rdi: 0x0000000000008422 rsi: 0x0000000000000006 rbp: 0x00007fff5fbfeba0 rsp: 0x00007fff5fbfeb88
    r8: 0x00007fff71126a60 r9: 0x000000010451e2e0 r10: 0x00007fff891a20fa r11: 0xffffff80002e4730
    r12: 0x0000000000000003 r13: 0x00007fff5fbfec50 r14: 0x0000000000000003 r15: 0x0000000000040801
    rip: 0x00007fff891a60b6 rfl: 0x0000000000000206 cr2: 0x0000000104128558@

    Thank you very much!

    Tulaya


  • Moderators

    So what is the message qFatal is writing?



  • Thank you Tobias Hunger for your prompt reply. The problem is resolved now. I was about to post how it worked when I realized my reply to your post wasn't sent!

    The message was QWidget: Must construct a QApplication before a QPaintDevice.

    Not knowing that I haven't replied, I googled around and around and finally decided to use macdeployqt rather than manually copy the libraries and change the references. And now the app package did work. I used QtWebKit and apparently there were steps I missed specific to this.

    Thanks!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.