Using QT5 on windows



  • Hello,

    I am using windows 8 and I want to use QT5.
    I only have Visual Studio 2012 installed but QT5 is shipped with the visual 2010 compiler. Does this mean I have to install visual studio 2010 to use QT5 on windows?

    Or can I use different compilers like vs2011 or mingw?

    Atm QT tells me:
    No compiler can produce code for this QT version.



  • To use it with VS2012 or MinGW you will need to build Qt framework yourself (with the compiler you want to use) - "here":releases.qt-project.org/qt5.0/rc2/single/qt-everywhere-opensource-src-5.0.0-rc2.zip is a link to RC2 source code.

    //you can search on doc/wiki on how to build Qt - and also ask here if something isn't clear.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.