Running the examples in Qt5



  • I downloaded and installed Qt5, then opened one of the examples, Affine Transformations, and found the code. So I tried to build the application from the run button. No good! An information box shows "Qt Creator needs a compiler set up to build. Configure a compiler in the kit options". So I went into the tools/options/kits selection and can see "Auto-detected Desktop Qt5.0.0-rc1 MSVC2011 32 bit (SDK) (default)" in the listing. Clicking on the yellow information icon now shows a lot of text boxes that are already filled in, but the one that seems to be causing the problem is the box labelled compiler showing "no compiler available". I thought that this download contains everything needed to use this development environment including a compiler. Am I wrong, and what do I do to fix the installation so I can run the examples.


  • Moderators

    No, a compiler is not included. We can not ship the Microsoft compiler for obvious legal reasons. The mingw will not work with this one either.

    You will need a compiler that is compatible with your Qt version. Looks like you will need MSVC2011.



  • I did a google search for MSCV2011 and came up with no sites at all to download your compiler suggestion. Since your suggestion implies an open source for this compiler I would sure like to know where to find it on the web as this Qt tool is useless without it.


  • Moderators

    I never implied that the compiler is open source! If it was open source then we might actually be able to ship it, but it is proprietary code written and owned by Microsoft.

    You can download it AFAIK as part of the windows SDK or visual studio express installations, both being available from Microsoft. I am no windows user though, so I can not tell you which version of the compiler is in which WinSDK, sorry.



  • I've been working on this thing for the past 3 weeks! You are correct about the MS compiler, but I did make the mistake of trying the standalone compiler instead (which didn't work) and installed the whole VS package, which did show up in the Qt compiler listing so that I can now use it. I also tried the minGW version on another computer but that is another discussion since it also seems to have the same problems. Anyway, the MS version now shows up and builds and runs several of the examples which I could not do at all before. When I try to compile the Composition Modes example the compiler gives me the following error "LNK1181: cannot open input file 'demo_shared.lib'"! I did a file seek for this file on the computer and the file is not on the computer anywhere! Maybe you can figure this out as I have no clue what to do with this problem. Maybe fixing this problem will get the whole thing up and running so that I can start usig this IDE.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.