QT Creator Debugger Skips all Breakpoints



  • I am not entirely certain this is a QT issue but would certainly appreciate any help to resolve this. Upon launching any application in QT Creator in debug mode, the application runs but breakpoints are ignored. The appear to be set to <PENDING> status in the debugger. The application is built in debug mode.

    The debug log reports the followin upon issuing breakpoints:

    @

    30^done,files=[]
    31^done,BreakpointTable={nr_rows="0",nr_cols="6",hdr=[{width="7",alignment="-1",col_name="number",colhdr="Num"},{width="14",alignment="-1",col_name="type",colhdr="Type"},{width="4",alignment="-1",col_name="disp",colhdr="Disp"},{width="3",alignment="-1",col_name="enabled",colhdr="Enb"},{width="10",alignment="-1",col_name="addr",colhdr="Address"},{width="40",alignment="2",col_name="what",colhdr="What"}],body=[]}
    <32-break-insert -f ""GLWidget.cpp":21"
    &"No symbol table is loaded. Use the "file" command.\n"
    32^done,bkpt={number="1",type="breakpoint",disp="keep",enabled="y",addr="<PENDING>",pending="\"GLWidget.cpp":21",times="0",original-location="\"GLWidget.cpp":21"}
    dALL COMMANDS DONE; INVOKING CALLBACK
    dBREAKPOINTS SET, CONTINUING INFERIOR STARTUP
    dState changed from InferiorStarting(6) to InferiorRunningRequested(8).
    <33-exec-run
    @

    I am baffled by the message:
    @&"No symbol table is loaded. Use the "file" command.\n"@

    My current version of Creator is:
    Qt Creator 1.3.1
    Based on Qt 4.6.3 (64 bit)


  • Moderators

    Wow, you are still using 1.3.1? That version must be close to 3 years old by now.

    Please update to a more recent version of Qt Creator and post the complete debugger logs somewhere if the problem persists.

    Which OS are you actually running at?



  • I'm running Debian Squeeze 6.0 using Linux3.7 kernel. The standard (stable) Debian packages are typically behind. I'll check if there's backports with later QT versions. The complete log can be viewed at: "http://pastebin.com/wXYCaJCH":http://pastebin.com/wXYCaJCH



  • Ok Tobias, I am no longer running Debian Squeeze 6.0. In order to run QTCreator 2.5, I had to perform an entire system updgrade - to The Debian testing repo, wheezy. It is a little more up to date, but a little less stable. The issue did go away, however.

    Also, the re-install updated the XLibs (namely, gl drivers, mesa etc.) that the old version pointed to which were dated (I had created a sid-by-side custom X install to try to get QTGL to compile.) Wheezy, running Gnome3 is ok.

    I get the feeling that I am of a small constituency of openGL developers running QT in Debian. I prefer it for a number of reasons and QT isn't the only development system I run on this machine.

    At any rate, I followed your advice and solved the problem but, that was like slitting your throat to cure a headache. I understand that the kneejerk versioning reaction is the easiest answer to give but, I was just looking for a hand in understaning how to work with what I had.

    I really would have appreciated a more thoughtful indicator but, you probably have to triage many issues and fires etc. so I understand. Please direct any other developers attempting to develop OpenGL on QT to me. I've gone through massive pains and heartache to get GLSL versions > 1.3 to run which led me to this state. We're all supporting the same cause and I have learned much recently by making many, many, unguided errors.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.