Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct
Qt installation problem(invalid version of w32api.h)
ttgump last edited by
Hi, I am trying to install Qt4.8.3 in windows with minGW. I have installed minGW in my computer, when installing qt, it says can't find invalid w32api.h. It need a version of 3.1.1 but mine is 3.1.7. Can I continue installation? Is there any problem to run qt with new version of minGW?
The Qt 4.8.x DLLs on the website are incompatible with GCC 4.7 unfortunately. You have two options:
Download an older version of GCC -- The offically supported version is GCC 4.4 (ftp://ftp.qt.nokia.com/misc/MinGW-gcc440_1.zip ), but people report that GCC 4.6 also works
Use GCC 4.7 to build Qt 4.8.x yourself from the source code
P.S. I think you meant w32api.h versions 3.13 and 3.17
vincenet last edited by
Sorry to active this old thread...
I would like to download a ming version appropriate (I have same problem). Since nokia's link JKSH mentioned not work anymore, I go to http://sourceforge.net/projects/mingw/files/Installer/ but I do not know how to find older version of mingw. At the first time I downloaded with link "Looking for the latest version? Download mingw-get-setup.exe (86.5 kB)" (inappropriate recent version !)