Correctly installing 4.8.3 debug versions and QT source on Mac OS X?



  • I have installed Qt 4.8.3 binary and debug binaries as well as Creator 2.6 on Mac OS X (10.8.2). Most is well, except when I try to debug stepping into QT source (e.g. QTGui).

    Debugging my own code works fine... but on startup, I get the following errors:

    Debugging starts
    Unable to read symbols for QtGui.framework/Versions/4/QtGui (file not found).
    Unable to read symbols from "QtGui" (not yet mapped into memory).
    Unable to read symbols for QtCore.framework/Versions/4/QtCore (file not found).
    Unable to read symbols from "QtCore" (not yet mapped into memory).

    The files referenced, QtGui.framework/Versions/4/QtGui and QtCore.framework/Versions/4/QtGui both seem to exist where I would expect, in /Library/Frameworks

    Do they need to be somewhere else? I would also assume that the Qt source needs to be somewhere standard. I have downloaded and unzipped the source tree, but the Install file contains URLs to old Nokia pages that no longer exist, so I don't know where the compiled debug libraries expect the source to be in the directory structure.

    Any suggestions would be very welcome!

    Glenn



  • Did you solve this? I have exactly the same problem with the same QT versions and system!!!

    Anyone?



  • Zorlettte:

    I have not solved this yet, but I think I know what the solution is... I ran across a discussion concerning "frameworks" on the Mac replacing more traditional Unix/Linux style shared libraries. The note suggested that the debug frameworks have to be manually substituted for the non-debug versions when one wishes to debug into the QT libraries.

    I have not yet tried this.

    Glenn


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.