QtCreator 2.6.0 doesn't work with Microsoft 64-bit compiler ver. 7.0 ( MSVC 2010 ) ?



  • Hello,

    I work with VisualStudio but recently I decided to take a look at QtCreator and downloaded Qt 5.0beta2 SDK. Everything worked ok. Now I try to create a new kit for Qt4.8.3 64-bit. QtCreator autodetected following configurations :

    Microsoft Visual C++ Compiler 10.0 (amd64)

    Microsoft Windows SDK for Windows 7 (7.1.7600.0.30514) (amd64)

    Problem is that there is no such configuration as amd64. In Windows SDK 7.0 64-bit compiler is called x64. I have only MSVC2010 Express and it doesn't contain 64-bit tools at all, so I wonder how QtCreator could detect Microsoft Visual C++ Compiler 10.0 (amd64) ( apparently it doesnt work either ). I tried to replace /amd64 switch with /x64 but the edit field is disabled ( even if I clone the compiler item ). I cant add a new compiler too. The only options I have areClang,GCC,MinGW`. I'm stuck.

    Am I missing something ? What should I do now ?

    Thanks in advance ...


  • Moderators

    There is a patch for this issue that will be in Qt Creator 2.6.1.

    It will also be in the next Qt5 release package (even if that will most likely contain a Qt Creator 2.6.0, but we will need to add some patches for the Qt5 library renaming that happened after beta2 anyway).

    If you care to build Creator yourself you will need adc8dc7bfb2ed8bc1d28cbbcb5e0a67f18fc6f2b which was pushed into the 2.6 branch.



  • It works now, thanks ...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.