Plugin loading fails on Windows 7

  • Hi all,

    I am developing application which uses Qt plugin architecture. Main application loads my other Qt plugins by using QPluginLoader.

    Normally application works fine in Windows XP, Vista and 7 64bit. But now I have faced one Windows 7 64bit PC which constantly fails on plugin loading.

    QPluginLoader returns this kind of error message:
    @The plugin 'C:/My projects/TestApplication/Plugins/GUI/MainGUI.dll' uses incompatible Qt library. (3.7.0) [release]@

    I am using Qt version 4.8.1 and my installer is delivering Visual Studio 2008 redistributable packet. User who tries to execute this application belongs to Administrator usergroup.

    I have searched Qt dlls from this computer E.g. if some other application is delivering older versions from Qt dlls but there isn't any. I have also added my application to be the first one in PATH environment variable.

    I have also tried to use depwalker to figure out if there is missing some depended dlls but it looks ok.

    Weird thing here is that if I run this application as a Windows Service and by using SYSTEM user it works fine. But again if I try to run this service under local user account it fails like before.

    Have anyone faced this kind of issues before? Any help and ideas would be appreciated :-)


  • Well, the message is quite explicit. It looks like you are trying to load a plugin which was compiled against a 3.7.0 version of Qt. Could it be in some path only accessible by the user account ?

  • I have double checked that there isn't any other qt dlls present.

    If I clear qt pluging cache (HKEY_CURRENT_USER\Software\Trolltech\OrganizationDefaults) application is able to load plugins but they are behaving weirdly. For example QDateTime::currentDateTime() returns datetime with year 3000 something and also other native Qt classes are behaving badly.

    After this execution round it seems that loading is marked to be bad and QPluginLoader will start returning that specific error message and will not load them again before clearing qt plugin cache again.

    Is that Qt version 3.7.0 actually even valid for Windows platform?

Log in to reply