Important: Please read the Qt Code of Conduct -

Qt Creator slowing down entire computer

  • For some reason, it's suddenly taking much longer than it used to for Qt Creator to run QMake or build my project. After it's finished it slows down my computer to the point that new windows take an entire minute to open. When I start a build, the fan turns on and the CPU starts running at full power, and it never stops. The fan keeps running and the processor keeps processor at its full 3.1 Hz even after I close Qt Creator. When I then try to shut down the computer, I get a screen telling me Windows is waiting for a program to finish its task. That program is explorer.exe, and the task its finishing is playing the log off sound.

    All this only happens after I try to build my project. What is going on all of a sudden?

    [Edit: [i] and [/i] aren't valid formatting tags on here; edited formatting for you. -- mlong]

  • Moderators

    Which version of Qt Creator are you using? Which Windows version?

    (Also, I hope you mean 3.1 GHz... otherwise I think I might see part of your problem ;-) )

  • GHz it is. And thanks for the formatting tip. I'm using version 2.5.2 with Qt version 4.8.3 on Windows 7 home premium. It worked fine at first, but now...I don't know, it's like it's not cleaning up after itself properly or something. :?

  • Moderators

    Creator uses a lot of memory to hold the code model. Are you running low on memory? The computer will then push currently unused memory out to the harddisk which can cause such slowdowns.

  • I've got 5.89 GB of RAM available, with another 6 GB virtual memory available. Is that enough, generally?

  • Moderators

    That entirely depends on what else you are doing while running creator and on the project you are working with.

    The 6GB virtual memory don't really count: Those are what is slowing down your the computer when they are used. Being slow is of course better than to crash for running out of memory.

  • My problem, though, is that Qt Creator is suddenly taking forever to build a project that a week ago had been building in less than five seconds, plus my computer stays slow even after I close out of Qt Creator.

    To make sure it wasn't just the project, I loaded up a prior, even simpler project that had built just fine some three weeks ago. It, too, takes forever to build, even though I haven't made any changes at all. I don't see what could have changed to make Qt Creator so slow all of a sudden.

  • Hi!

    I have been working on a project since 2 months now. No QT updates and no system changes!
    Wanted to start working yesterday and i have the same problem!

    I am using MINGW with QT 4.8.3 with Creator 2.4.1.

    I have exactly the same problem like you fiodis! I didn't even change any settings!
    I shut down my computer on friday and booted it on tuesday and if i wanted to compile the latest version of my project it starts to slow down my windows explorer!
    I can even play games without problems (once they start) but the explorer itself (and QT compiling actions) are soooooooooooooooooooooooooooo slow.
    Maybe it has smth to do with hard disk access?

    This behaviour only appears if i compile ANYTHING with QT.

    My next step is to reinstall QT!

    EDIT: And my CPU is working on something. It continues working at 26% on all cores! Even if i close QT! (like fiodis said) My Task Manager does not show any process that is causing it.

  • OK! I solved the problem! Reinstalled the hole thing!

  • Moderators

    It would have been nice if somebody would have found the root cause. We can not really fix this without a hint as to what is wrong.

  • That is really hard to say! Especially when windows doesn't really recognize which process causes the problem. The CPU was at 25% even after closing QT Creator. But the Task Manager didn't show a process which used more than 0%.
    This behaviour appears like a driver problem. But I can't tell.

  • Moderators

    OK, let's just blame it on the driver then;-)

  • By "reinstalled the whole thing" you mean Qt Creator, MINGW, Qt itself, or all three?

  • No... I reinstalled my windows because i wanted to have Win8 anyways. (Sorry...)
    But I'd try to uninstall every QT software from your system and then install 4.8.4 with creator 2.6.0. Please let me know if that worked if i get the problem again! ;)

    [quote author="Tobias Hunger" date="1355157395"]OK, let's just blame it on the driver then;-)[/quote]

    I don't even know what drivers QT is using or not! ;) But these problem appears like a driver problem from my experience. (I know... It is just a brainstorming input from my side)
    If i had the time to invest more time in QT than in my project, I would have questioned it a bit more. Sorry for that!

    [Moderator's note: Removed duplicate post -- mlong]

  • OK!

    I have the problem again!
    This time I updated to QT5 rc2 with Creator 2.6.1
    I also installed Visual Studio 2010. I compiled my project with the msvc2010 compiler and then with MinGW QT4.8.4
    And YAHTZEE! Same behaviour like the last time. But this time I am using Windows8.

    I'm now going to reinstall the whole Qt stuff. If this wont change anything, I will uninstall my Visual Studio.

    The only thing which is maybe special on my project is, that it is very huge meanwhile. It consists of 3 separate frameworks.
    Does Qt Creator have something like an index database or something? Maybe it would help to delete it.

  • OK Another thing:
    Windows8 task manager shows more details of processes and services.
    It shows up that the Kaspersky Service starts continuously filling my RAM!
    It now has 1.5 GB reserved within 2 minutes! And the service runs at 28% CPU at all 4 cores!!!
    Another Kaspersky service called "Dump Writer" fully loads my hard disk at 99%!!!!! WTF?

    But it only starts doing that when I compile anything with Qt Creator/MinGW

    Sometimes when I compile anything, Kaspersky says: "qmake.exe/QTCreator has simmilar behaviour like root shell smth smth"

    I don't get it. It worked for 3 weeks now and all of a sudden. BAM

    What could be the problem?

  • I also recognized, that the problem doesn't appear with Creator 2.6.0!

  • Moderators

    Anti virus apps do all kind of strange things. I tend to just turn them off (or better: Ask them to ignore my development folders) whenever using windows. Even if they do not cause hassel they slow down compiling a lot and that already feels slow on windows, even without a AV looking over its sholders.

  • Same problem here...
    Disable anti-virus solved the problem

  • Moderators

    jack249: If possible just ask the AV to ignore your source/build directories. Don't turn of virus protection completely.

Log in to reply