How to install Qt Beta or RC versions



  • I want to I install Qt Creator 2.1 RC and Qt 4.7.1 libraries on my old installation (Win XP/MinGW).
    Is this a good idea or would it be better to de-install the 2.0.1 package first?

    Is there a howto available?



  • I have both versions of Qt Creator installed RC and the older one. No issues faced.



  • You will may install QtCreator on old installation, but I don't recommend install Qt on old version. Better remove old version before. Or you will may install new Qt to another directory.



  • [quote author="Vass" date="1291632069"]You will may install QtCreator on old installation, but I don't recommend install Qt on old version. Better remove old version before. Or you will may install new Qt to another directory.[/quote]

    I forgot to mention that I have it installed in a separate folder.



  • @QtK, Vass: thanks I'm trying...

    ...what about starting a howto, maybe in the wiki, or is it too trivial?



  • For QtCreator it is very trivial process.
    For Qt, I don't know what you install: SDK or Build source, or something else.



  • [quote author="Wolf P." date="1291632404"]@QtK, Vass: thanks I'm trying...

    ...what about starting a howto, maybe in the wiki, or is it too trivial?[/quote]

    I feel its too trivial. But let us know if there is any special case may be in that case we can have a wiki article.



  • ...or add a section to the "Qt Creator FAQ":http://developer.qt.nokia.com/wiki/QtCreatorFAQ ?



  • guys i have like 4 versions of creator on my laptop .. other than workspace which they all seem to share and fetch the same "recent projects" .. no overlap issues I've seen so far from my day to day regular usage ..

    i've installed them in different directories and two of them came with sdks



  • Wolf, no problem to have as many versions installed as you wish. In case of compiling from a command line, environment variables must be set correctly (point to proper version)



  • I also have many versions installed... I end up installing the nokia sdk, the meego sdk, qt 4.7 (w/creator), qt creator beta, ... I don't even know what I have installed anymore... to my surprise I haven't had any issues...



  • no issues if the needed Qt version is specified within IDE (QtCreator or MS VS + VS add-in).

    If you use CMake, the needed Qt version must be in env variables (as for command line compiling) or specified explicitly.



  • I also have installed many versions of Creator: the packages from Debian, the Nokia Qt SDK and the 2.1 RC of Creator. All use different prefixes, so it's not a problem.

    If I were you, though, i would uninstall the old one if you don't need it.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.