Integrate QT in the newest Eclipse CDT for C/C++ programming [SOLVED] THERE IS A TOOL for this



  • Hello Guy's,

    I'm very new with programming in QT. I have installed the newest eclipse version and updated with cdt for c/c++ programming. After that I installed the latest qt opensource version. How can I integrate QT in my eclipse verison with all the features. I have seen that some people using eclipse with all the awesome features and libraries from qt.

    There is no good tutorial for this specified problem. Almost all the links are death-links.

    Kind regards,



  • Now I geht the clou with the installation....

    I tried to compile an empty project but it didn't resolved the different functions.

    @helloworld.cpp
    #include "helloworld.h"

    helloworld::helloworld(QWidget *parent)
    : QMainWindow(parent)
    {
    ui.setupUi(this); //Unresolved ERROR
    }

    helloworld::~helloworld()
    {

    }
    @

    @helloworld.h
    #ifndef HELLOWORLD_H
    #define HELLOWORLD_H

    #include <QtGui/QMainWindow>
    #include "ui_helloworld.h" //Unresolved ERROR

    class helloworld : public QMainWindow
    {
    Q_OBJECT

    public:
    helloworld(QWidget *parent = 0);
    ~helloworld();

    private:
    Ui::helloworldClass ui; //Unresolved ERROR
    };

    #endif // HELLOWORLD_H

    @

    @#include "helloworld.h"

    #include <QtGui>
    #include <QApplication>

    int main(int argc, char *argv[])
    {
    QApplication a(argc, argv);
    helloworld w;
    w.show();
    return a.exec(); //Unresolved exec();
    }
    @



  • Hi,

    Please write one problem per post. It will be easier to read and answer for it.

    Did you successfully install Qt plugin for Eclipse?



  • Hello Guziemic,

    first of all sorry for the confusing answers.

    There was one problem in the installation of theqt plugin. It was about MinGW. I installed before and give the plugin the correct path but it said that it couldn't found the path.

    I have installed QT. 4.8.3 and the latest mingw version. Also I have setted all relevant pathvariables of MinGW in my enviroment variables.

    Also I get an unresolved erroer at setuipUI in my class for the ui.
    @#include "bluesmar.h"

    BlueSmar::BlueSmar(QWidget *parent)
    : QMainWindow(parent)
    {
    ui.setupUi(this); //Unresolved <-----------
    }

    BlueSmar::~BlueSmar()
    {

    }@

    All of all I get now the error Message:
    c:\Qt\4.8.3\include/QtCore/../../src/corelib/global/qglobal.h:45:20: fatal error: stddef.h: No such file or directory

    Snapshoot of my Console:
    @09:41:04 **** Build of project BlueSmar ****
    mingw32-make debug
    mingw32-make -f Makefile.Debug
    mingw32-make[1]: Entering directory D:/Entwicklung/SmartBlue/BlueSmar' c:\Qt\4.8.3\bin\uic.exe bluesmar.ui -o ui_bluesmar.h g++ -c -g -Wall -Wextra -fno-exceptions -fno-rtti -DUNICODE -DQT_LARGEFILE_SUPPORT -DQT_GUI_LIB -DQT_CORE_LIB -DQT_THREAD_SUPPORT -DQT_NEEDS_QMAIN -DQT_NO_DYNAMIC_CAST -I"c:\Qt\4.8.3\include\QtCore" -I"c:\Qt\4.8.3\include\QtGui" -I"c:\Qt\4.8.3\include" -I"c:\Qt\4.8.3\include\ActiveQt" -I"debug" -I"." -I"c:\Qt\4.8.3\mkspecs\default" -o debug\main.o main.cpp In file included from c:\Qt\4.8.3\include/QtCore/qglobal.h:1:0, from c:\Qt\4.8.3\include/QtCore/../../src/corelib/global/qnamespace.h:45, mingw32-make[1]: Leaving directoryD:/Entwicklung/SmartBlue/BlueSmar'
    from c:\Qt\4.8.3\include/QtCore/qnamespace.h:1,
    from c:\Qt\4.8.3\include/QtCore/../../src/corelib/kernel/qobjectdefs.h:45,
    from c:\Qt\4.8.3\include/QtCore/qobjectdefs.h:1,
    from c:\Qt\4.8.3\include/QtGui/../../src/gui/kernel/qwindowdefs.h:45,
    from c:\Qt\4.8.3\include/QtGui/qwindowdefs.h:1,
    from c:\Qt\4.8.3\include/QtGui/../../src/gui/kernel/qwidget.h:45,
    from c:\Qt\4.8.3\include/QtGui/qwidget.h:1,
    from c:\Qt\4.8.3\include/QtGui/../../src/gui/widgets/qmainwindow.h:45,
    from c:\Qt\4.8.3\include/QtGui/qmainwindow.h:1,
    from c:\Qt\4.8.3\include/QtGui/QMainWindow:1,
    from bluesmar.h:4,
    from main.cpp:1:
    c:\Qt\4.8.3\include/QtCore/../../src/corelib/global/qglobal.h:45:20: fatal error: stddef.h: No such file or directory
    compilation terminated.
    mingw32-make[1]: *** [debug/main.o] Error 1
    mingw32-make: *** [debug] Error 2

    09:41:05 Build Finished (took 562ms)
    @


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.