Qt5 Beta build from Git with qwinoverlappedionotifier error in Windows 7, mingw



  • Good day

    I followed the instructions http://qt-project.org/wiki/Building_Qt_5_from_Git and
    downloaded Qt5 Beta from the repository without the QtWebkit and tried to build it
    when I got this error somewhere in the build process:

    @
    cd qwinoverlappedionotifier\ && ( if not exist Makefile D:\qt5\qtbase\bin\qmake
    D:\qt5\qtbase\tests\auto\corelib\io\qwinoverlappedionotifier\qwinoverlappedionot
    ifier.pro -o Makefile ) && mingw32-make -f Makefile
    mingw32-make[6]: Entering directory 'd:/qt5/qtbase/tests/auto/corelib/io/qwinove
    rlappedionotifier'
    mingw32-make -f Makefile.Debug
    mingw32-make[7]: Entering directory 'd:/qt5/qtbase/tests/auto/corelib/io/qwinove
    rlappedionotifier'
    g++ -c -pipe -fno-keep-inline-dllexport -g -frtti -Wall -Wextra -fexceptions -mt
    hreads -DUNICODE -DQT_DISABLE_DEPRECATED_BEFORE=0 -DQT_DLL -DQT_TESTLIB_LIB -DQT
    _CORE_LIB -DQT_TESTCASE_BUILDDIR="D:/qt5/qtbase/tests/auto/corelib/io/qwinoverl
    appedionotifier" -I. -I"..........\include" -I"..........\include\QtTes
    t" -I"..........\include\QtCore" -I"..........\include\QtCore\5.0.0" -I"
    ..........\include\QtCore\5.0.0\QtCore" -I"tmp\moc\debug_shared" -I"......
    ....\mkspecs\win32-g++" -o tmp\obj\debug_shared\tst_qwinoverlappedionotifier.o
    tst_qwinoverlappedionotifier.cpp
    tst_qwinoverlappedionotifier.cpp: In member function 'void tst_QWinOverlappedIoN
    otifier::readFile()':
    tst_qwinoverlappedionotifier.cpp:144:31: warning: missing initializer for member
    '_OVERLAPPED::InternalHigh' [-Wmissing-field-initializers]
    ...
    ... More Errors in tst_qwinoverlappedionotifier.cpp [excluded to shorten post]
    ...
    Makefile.Debug:1046: recipe for target 'tmp/obj/debug_shared/tst_qwinoverlappedi
    onotifier.o' failed
    mingw32-make[7]: *** [tmp/obj/debug_shared/tst_qwinoverlappedionotifier.o] Error
    1
    mingw32-make[7]: Leaving directory 'd:/qt5/qtbase/tests/auto/corelib/io/qwinover
    lappedionotifier'
    Makefile:33: recipe for target 'debug' failed
    mingw32-make[6]: *** [debug] Error 2
    mingw32-make[6]: Leaving directory 'd:/qt5/qtbase/tests/auto/corelib/io/qwinover
    lappedionotifier'
    Makefile:739: recipe for target 'sub-qwinoverlappedionotifier-make_first' failed

    mingw32-make[5]: *** [sub-qwinoverlappedionotifier-make_first] Error 2
    mingw32-make[5]: Leaving directory 'd:/qt5/qtbase/tests/auto/corelib/io'
    Makefile:124: recipe for target 'sub-io-make_first' failed
    mingw32-make[4]: *** [sub-io-make_first] Error 2
    mingw32-make[4]: Leaving directory 'd:/qt5/qtbase/tests/auto/corelib'
    Makefile:49: recipe for target 'sub-corelib-make_first' failed
    mingw32-make[3]: *** [sub-corelib-make_first] Error 2
    mingw32-make[3]: Leaving directory 'd:/qt5/qtbase/tests/auto'
    Makefile:38: recipe for target 'sub-auto-make_first' failed
    mingw32-make[2]: *** [sub-auto-make_first] Error 2
    mingw32-make[2]: Leaving directory 'd:/qt5/qtbase/tests'
    Makefile:89: recipe for target 'sub-tests-make_first' failed
    mingw32-make[1]: *** [sub-tests-make_first] Error 2
    mingw32-make[1]: Leaving directory 'd:/qt5/qtbase'
    Makefile:59: recipe for target 'module-qtbase-make_first' failed
    mingw32-make: *** [module-qtbase-make_first] Error 2@

    I deduced that the error was in the QtBase tests folder and would not influence the basic functions and tried to compile a simplistic program with qmake and mingw32-make and got the following output:
    @d:\temp>mingw32-make
    mingw32-make -f Makefile.Debug
    mingw32-make[1]: Entering directory 'd:/temp'
    g++ -c -pipe -fno-keep-inline-dllexport -g -frtti -Wall -Wextra -fexceptions -mt
    hreads -DUNICODE -DQT_DLL -DQT_GUI_LIB -DQT_CORE_LIB -DQT_NEEDS_QMAIN -I. -I"."
    -I"..\qt5\qtbase\include" -I"..\qt5\qtbase\include\QtGui" -I"..\qt5\qtbase\inclu
    de\QtCore" -I"debug" -I"..\qt5\qtbase\mkspecs\win32-g++" -o debug\temp.o temp.cp
    p
    g++ -Wl,-subsystem,windows -mthreads -o debug\temp.exe debug/temp.o -lglu32 -lo
    pengl32 -lgdi32 -luser32 -lmingw32 -lqtmaind -LD:/qt5/qtbase/lib -lQtGuid5 -LD:/
    qt5/qtbase/lib -lQtCored5
    mingw32-make[1]: Leaving directory 'd:/temp'@

    It compiles an exe file that does nothing. Compiling the .cpp file with mingw32-make directly, a correct working exe file is produced, thus I assume nothing is wrong with my mingw.

    Can someone pleas assist me?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.