A procedure entry point .... could not be located in the dynamic link library QtCore4.dll when running qt application built as console app.



  • Dear friends,

    Can sombody hint to resolve next case:

    I created Qt console application in Qt Creator 2.4.1 built with Qt 4.7.4 ( 32 bit ) on Windows 7 x64 machine.
    In the application .pro file next rows putted:

    @QT += core

    TARGET = LMB
    CONFIG += console
    CONFIG += release
    CONFIG -= app_bundle

    TEMPLATE = app@

    ...

    together with includes and pathes to external libs that I use ( I work with STASM , - computer vision library and with OpenCV ).

    the application contains only 1 main.cpp file with few functions,

    next are included in the main.cpp:

    @#include <QtCore/QCoreApplication>@

    together with opencv and stasm includes and the main function is:

    @int main(int argc, char *argv[])
    {
    QCoreApplication a(argc, argv);

    ...

    return a.exec();
    }@

    I build the app with installed toolchain - Qt 4.8.0 for Desktop with MinGW both in release and debug it is compiled well but next happens when I run it:

    when I run the executable built in debug from the Qt Creator with previously opencv .dlls and stasm dlls putted to the debug directory it runs fine as expected, but when I run it from the directory with the .dlls and the Qt .dlls:

    libgcc_s_dw2-1.dll

    mingwm10.dll

    QtCore4.dll and or QtCore4d.dll I get the message:

    A procedure entry point .... could not be located in the dynamic link library QtCore4.dll ...

    when built in release mode the application doesn't run even from the Qt Creator,

    I putted the .dll from Qt 4.8.0 for MinGW and all the .dlls are in the folder where I execute the .exe file built.

    I need the application to be run from console.

    Does anybody know what is the problem? Why a procedure entry point could not be located in this case?

    Thank you in advance for your help.



  • I don't see any sources listed in your .pro file, you should have a line similar to this:
    @
    SOURCES += main.cpp
    @



  • Hi Terence,
    Unfort. that is not the problem/reason, I have the source main.cpp listed in my .pro file of course.
    There is some another problem/reason. With the .dlls needed to run executable.
    What is it ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.