QtCreator: How to turn off function tooltip to show autocomplete list?



  • Hi everyone,
    When I type a function name and its open parenthese a tooltip appear and the autocomplete list won't show when I type the first parameter of the function, and I have to press Esc key to turn it off. I searched in options dialog but couldn't find an option about it, so how to turn off this tooltip automatically?
    Thanks!


  • Moderators

    Never noticed that... which version of creator are you using? Where did you get it from?



  • Thanks for your reply.
    I use QtCreator 2.4.1 ships with QtSdk 1.2.1 (Windows XP 32bit)
    Previous versions of QtSdk has the same problem too.


  • Moderators

    The SDK is rather unfortunately rather outdated by now:-( It might be worth trying a newer creator, even though I am actually not aware of any fixes in this area.

    If you want to keep your SDK settings you can just copy the QtCreator/share/qtcreator/Nokia from the SDK into the same place of a stand-alone Qt Creator installation. That works with Qt Creator 2.5.x, 2.6 has a slightly different format and won't parse that anymore.



  • I has just downloaded and tried QtCreator 2.6.0-beta, the problem is fixed.
    Thanks for your help!



  • I apologize for necroing an old thread, but this is still a thing in QT 4.2.1. A lot of the time, when I want autocomplete to show, a tooltip telling me what the method I'm currently calling should include pops up instead, sometimes blocking the line above as well so I can't see what I actually want to type. Is there a way to turn this off?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.