Configure.exe -no-webkit problem



  • Hi all,

    I've tried to compile Qt 4.8.3 statically with MinGW. I've run configure.exe with the following options. But the process of the compilation has failed because of webkit although I've added the option of -no-webkit. How can I solve this problem?

    configure.exe -static -release -opensource -confirm-license -platform win32-g++ -no-exceptions -no-qt3support -qt-sql-sqlite -qt-zlib -qt-libpng -qt-libjpeg -no-webkit

    ...
    mingw32-make[4]: Leaving directory C:/QtSTATIC/4.8.3/src/3rdparty/webkit/Source/WebKit/qt/tests/qwebframe' mingw32-make[3]: Leaving directoryC:/QtSTATIC/4.8.3/src/3rdparty/webkit/Source/WebKit/qt/tests/qwebframe'
    mingw32-make[2]: Leaving directory C:/QtSTATIC/4.8.3/src/3rdparty/webkit/Source/WebKit/qt/tests' mingw32-make[1]: Leaving directoryC:/QtSTATIC/4.8.3/src/3rdparty/webkit/Source'
    ...
    mingw32-make[4]: *** [release\tst_qwebframe.exe] Error 1
    mingw32-make[3]: *** [release] Error 2
    mingw32-make[2]: *** [sub-qwebframe-make_default] Error 2
    mingw32-make[1]: *** [sub-Webkit-qt-tests-make_default-ordered] Error 2
    mingw32-make: *** [sub-webkit-make_default-ordered] Error 2

    Thanks advance for your helps and explanations,


  • Moderators

    What happens if you add"
    @
    -nomake tests
    @

    To this?



  • Thanks for quick response; I've cleaned temporary files and recompiled Qt with following configure options but the compilation has been failed with same error. How can I exclude webkit from the Qt's compilation?

    configure.exe -static -release -opensource -confirm-license -platform win32-g++ -no-exceptions -no-qt3support -qt-sql-sqlite -qt-zlib -qt-libpng -qt-libjpeg -no-webkit -nomake tests -nomake demos -nomake examples


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.