Building for Maemo gives Packaging error

  • Hi,

    I created a blank ("Hello world") Qt Quick application in Qt Creator 2.1 RC1. It compiles and runs nicely when the target is Desktop. However I wanted to test in N900, so I created a new Maemo device configuration Qt Creator. N900 seems to be configured correctly, since the "Test"-function in Maemo Device Configurations yields OK.

    The problem is that when I try to build on Maemo, either debug or release, I get:

    /sysroots/fremantle-arm-sysroot-20.2010.36-2-slim/sysroots/fremantle-arm-sysroot-20.2010.36-2-slim/var/lib/dpkg/status: No such file or directory
    dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.
    dpkg-buildpackage: warning: (Use -d flag to override.)
    Packaging Error: Command 'dpkg-buildpackage -nc -uc -us' failed.Exit code: 3

    I'm running Windows XP. Anybody else seen this error? How do I fix this?


  • Looks like something is broken in your maemo toolchain. Try to reinstall it, maybe something was corrupted.

  • As Denis said, it looks like an error in your build environment. Try what he suggested, then post the results here. :-)

  • anselmolsm, yeah, posting back will be really appreciated because someone later can stuck with similar problem.

  • Thanks for the replies, guys. Indeed when I reinstalled Qt SDK, the problem went away!

  • Sorry, I was a bit too quick there. I have Qt Creator 2.1 RC1 and 2.0.1. Deploying works in 2.0.1, but not in 2.1 RC1. 2.1 RC1 builds the app OK, but running Deploy Project still gives me the same packaging error.

  • Well, I uninstalled all Qt/Symbian dev tools, re-installed them, and now it finally agrees to work, even with Qt Creator 2.1 RC1.

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.