[SOLVED][Qt Creator][Static Library] Can't select a static library by GUI way in Qt Creator 2.5.0



  • Hi,

    I work with Qt Creator on Linux CentOS with GCC compiler.
    I want to add a static library (create with fortran g95 ) to my project by the GUI way.
    So, after right click on project , i select "add Library", i choose "external Library".
    When i select my static library the path is colored in red and nothing tell me why this library can't be add.
    I ve done the same thing on windows XP and it worked fine.

    Do you have any idea about what happened?

    Tx
    Frédéric



  • Hi,

    I ve found why ...If i renamed my static library "my_library.a" in this way : "libmy_library.a" it works!
    On Windows, Qt Creator seems to be more cool :)

    Now i ve new problem : "no rule to make target", but this post can be close.

    Frédéric


  • Moderators

    Which file did you select? Is that really a static library and not some wrapper script or something (what does "file /name/of/your/static/lib" say)?



  • Hi Tobias,
    Tx to answer.
    "file/name/of/your/static/lib” say : current ar archive

    Which i guess confirm that it is a static library.

    Frédéric


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.