Building QtTestBrowser standalone [SOLVED]



  • I used to be able to build QtTestBrowser in the /Tools/QtTestBrowser directory using:

    qmake .
    make

    after having built QtWebKit with Scripts/build-webkit.

    But now having cloned the latest WebKit, trying the above I am getting lots of link errors, i.e.
    /Tools/QtTestBrowser/launcherwindow.cpp:150: undefined reference to `QWebPage::mainFrame() const'

    Is there some environment variable I am missing?

    [SOLVED 9/25]
    I was able to solve my real problem - moving the project out from under WebKit - by adding the following environment variable:
    export QMAKEPATH='/yourpath/WebKit/Tools/qmake'

    [Update 9/25]
    Well, I thought I had it fixed. I was still getting same link errors, until I specifically pulled in WebKit1:
    WEBKIT += wtf webcore webkit1



  • OK, I have gotten past the first issue by adding the following to my .pro file:
    CONFIG -= production_build
    WEBKIT_CONFIG -= build_webkit2

    But now to the real problem. I made a copy of the project folder: QtTestBrowser2. If this folder lives ANYWHERE under the WebKit directory, it builds fine - qmake magically finds the Tools/qmake/mkspecs folder and all is good. If I move QtTestBrowser2 out from under WebKit, it no longer builds or finds Tools/qmake/mkspecs. There is nothing in the QtTestBrowser.pro that references Tools. Where is this magic occurring, and how can I make the project build without living under the WebKit folder?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.