[solved] (bug still filed - used workaround) Qt Creator and Qt 4.8.3 Library on Mac OSX - howto?



  • I had installed Qt Creator on my Mac (Osx Lion) and everything works fine. A few days ago the new 4.8.3 Library was released and I installed it today. Since the installer asked me for a password I guess it went somewhere under /Library/Frameworks/.
    But in Qt Creator there is no sign of it.
    So what am I to expect from the package?
    Do I "only" get the binary version of the library and the header files are used from the older version installed with Qt Creator?
    Shall I include the new library with the preferences pane? If so, where would the header files be or what directory is to be used?


  • Moderators

    The Qt stand alone installers don't know about creator, so they do not register it there. You will need to do that manually in Qt Creator: Go to Tools->Options->Build & Rub->Qt versions and add your new one. All you need is the path to the qmake that was installed with Qt 4.8.3.



  • On a Mac that would be -> Qt Creator / Preferences / Build & Run menu

    The path is
    /Developer/Tools/Qt/qmake
    but I can not choose it in the dialog: it's greyed out. That's certainly some OSX Lion f*ckery like the hidden Library folder for average users. If so it wouldn't be Qt's fault but what is the supposed way of doing it?


  • Moderators

    It might be our doing. We had some trouble on some flavors of linux with that before due to us limiting which files to display.

    Maybe filing a "bug report":http://bugreports.qt-project.org/ could help:-)



  • Thanks, I will give it a try :-)





  • As it's impossible to add 4.8.3 via Qt Creator GUI I guess these settings are stored in a file and it would be possible to modify it manually but I'm trying to find where it's saved and I couldn't find it.

    Does anybody know where it is?



  • it to work?



  • Nope :-/
    But in the bug report somebody posted a solution today. I'll have to try this later at home.



  • [quote author="shock_one" date="1349174790"]I’ve found a workaround.

    1. Go to the folder with quake.

    2. Right click on it - Quick Look

    3. Space.

    4. At this moment quake must be inactive but has a selection line on it. So simply press Open.

    5. ???

    6. PROFIT!

    P.S. Don’t forget to add the documentation.[/quote]

    I don't know if it's my Qt Creator and OS X versions (2.4.1 and OS X ML 10.8.2) or I don't understand it but that doesn't work for me. I can't select qmake to make a secondary click on it neither in the alias in /Developer/Tools/Qt/qmake or in the folder /usr/bin/qmake-4.8.

    Also, I found a Qt Creator settings file inside Qt Creator bundle (Qt Creator/Contents/Resources/Nokia/qtversion.xml), but it doesn't work. First I tried to modify it to add Qt 4.8.3 and nothing changed in Qt Creator. Then I added 4.8.1 version manually as a new config using Qt Creator and the xml file wasn't modified so it seems this file isn't the settings file Qt Creator uses.



  • Well, I made it work the hard way :)

    1. Copy the file /usr/bin/qmake-4.8 to the folder /Developer/Tools/Qt/ and rename it to qmake, replacing the qmake alias that is placed originally in that folder.
    2. Add Qt 4.8.3 in Qt Creator preferences (now it's possible to select qmake)
    3. (Optional) Reverse the changes leaving a qmake alias in the folder /Developer/Tools/Qt/ that points to /usr/bin/qmake-4.8

    It's not a very polished way to do it but it works.



  • Yes, that works :-D Thanks!



  • With Qt Creator 2.5.84 (2.6.0-rc) it works again :-)



  • hardcodes.de, you can help me to install Qt Libraries and Qt creator for my Mac?



  • Well, I will try to do so. What OSX version have you got and what's your (detailed) problem?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.