[Solved] qt on mac OSx Lion - installation missing files



  • Now fixed :) - see below

    Hi everyone,
    I'm new to Qt and having a few problems with my installation on my macbook. I was hoping someone on here may have experienced similar issues and could help get me rolling again :)

    I attempted to install from QtSdk-online-mac-x86-v1-1.2.1.dmg. The process got a long way through and then crashed. I received numerous error messages whilst installing relating to objects / files which could not be found. I clicked cancel or ignore (can't remember which) for all of them. I now seem to have half an installation on my mac and no easy way to start afresh as the QtSDK Maintenance Tool is missing from my installation.

    On opening Qt developer I get the following error message:

    !http://www.flickr.com/photos/86041963@N04/7882209222/(error message on opening)!
    "Sorry, can't get photo's to link properly. Album here..":http://www.flickr.com/photos/86041963@N04/with/7882209222/#photo_7882209222

    I am able to run Qt developer but not to compile projects. If I select remote compiler I get the following error message:

    !http://flic.kr/p/d1wMKC(remotecompilererror)!

    I can't compile locally either:

    !http://www.flickr.com/photos/86041963@N04/7882200124/(compiler error)!

    I'm running Mac OS X Lion version 10.7.4 (11E53), with XCode Version 4.4.1 installed (4F1003) on a 64 bit 2009 macbook. The mac user account I'm using is an admin account (I have two of them on this laptop).

    If anybody has any suggestions then they would be greatly appreciated. I can provide more info if it would be useful :)

    Thank you,
    Simon



  • Solved :)

    I'm looking forward to making some apps.

    It seems that gcc is not installed with Xcode 4.4.1 be default. In Xcode go select Xcode>Preferences>Downloads and select command line tools. I waited for it to install, closed Xcode then reinstalled qt in the same location (user directory>QtSDK).

    from
    mac forums

    "I had the same problem today. I just installed Xcode for Lion and have not used it. After getting the error, I opened a shell and typed "gcc" and got "command not found". Then I opened Xcode, accepted the terms of usage stuff and downloaded and installed everything that was not installed by default. The first thing that went in was the "command line tools". I believe this is what gave me my gcc back and after that the Qt install worked and did not throw any warning.

    2 cents!"


  • Moderators

    Glad you got it solved! Be sure and edit your initial post to add [Solved] to the title. Thanks!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.