Problem regarding building QtMobility for Desktop on Window



  • Hello, for several days, I have been installing and uninstalling QtSDK and QtMobility for Window Desktop, with both MinGW32 and VC 2008, but still no luck. These are what I have tried, please point out what I have done wrong while building:

    • Installed Active Pearl.

    For MinGW32:

    • Fresh install QtSDK 4.7.4 for MinGW, with MingGW 4.4. The Qt Desktop Directory is at:
      @C:\QtSDK\Desktop\Qt\4.7.4\mingw@

    • Unpack qt-mobility-opensource-src-1.2.0 to C:\

    • Open Qt 4.7.4 Command line, CD inside QtMobility Source folder, then run:
      @configure -prefix C:\QtSDK\Desktop\Qt\4.7.4\mingw@

    • After Running for a while, it say I can use mingw32-make. I run mingw32-make and mingw32-make install.

    • I Copy the pri key from symbian's Mobility inside the mkspecs\feature folder:
      @C:\QtSDK\Symbian\SDKs\Symbian3Qt474\mkspecs\features@

    • to Qt mingw32's mkspecs\feature folder:
      @C:\QtSDK\Desktop\Qt\4.7.4\mingw\mkspecs\features@

    • Now, I have the library for QtMobility, but the strange thing was, the QMobility's plugins are not inside the plugins folder, and I can't find It anywhere.

    • The Mobility Example compiled and build flawlessly, but it doesn't do anything (Like playing media, or recording, etc...)

    • Another things is the header files seem to missing or not installed correctly, since I can only include <qmediarecorder.h> but not <QMediaRecorder>.

    For VC2008:

    • Fresh Install QtSDK 4.7.4 for MSVC2008. The Qt Directory is at:

    @C:\QtSDK\Desktop\Qt\4.7.4\msvc2008@

    • Unpack qt-mobility-opensource-src-1.2.0 to C:\

    • Run configure with QT MSVC Command line, I install the SDK several times, and it gives me 2 cases:

    +It say no "nmake" or "mingw32-make" or "make" is installed. (This is when I remove all PATH related to nmake from my system PATH);

    +It say I can use "nmake" to install. I type nmake, enter, then the command line said that nmake is not a program or executable files. (This occur when I include nmake.exe inside VC9.0/bin directory in my personal PATH).

    • I can run VC 2008 just fine.

    I have wasted too much times on this, so my deadline get so near before i knew it (about 2 more days or so..)

    I really need QtMobility for my project, so Please Help me install this thing ones and for all!

    BTW, my machine is a 64 bit Window 7 Ultimate. I don't think Window version has anything to do with this, but just in case...



  • I have find a way to work around with this problem on minGW, (MSVC still got error).

    I used SDKv4.7.3 and 4.7.4 to install just some modules I need, and it run perfect, but it won't if I left it to install all modules.

    Seem like some of the modules's source cause the install progess to halt or something.

    The SDKv4.8.x won't install the mobility, I don't know why, but it won't.

    I will leave it as work around for now.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.