Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

App not closing when 'closed' [Solved]



  • I am having a very odd problem. I've written multiple Qt apps and for some reason this particular app will not close the process when I close the window. To test in my main window I have removed everything from the constructor so I end up with an empty window; I run the app, hit the close button and the window goes away but the process is still running. Not quite sure what is going on so I thought I would check here to see if anyone had some ideas?

    Thanks!



  • What does the debugger say? If you can't figure it out with debugger, try to reproduce the behaviour in a small test code that you can post here.
    LE: maybe a quick fix is qApp->setQuitOnLastWindowClosed(true);



  • Can you post the code ?



  • Turns out one of the 3rd party libs I was linking to was hanging things up. Fixed the problem.

    Thanks.


  • Moderators

    Be sure and edit your initial post to add [Solved] to the title. Thanks!



  • Ah, I was wondering how those' [Solved]'s were added. Thanks.


Log in to reply