Not working with n97



  • hey all

    I made an application just for test and when i make sis file and install it on my mobile ( n97 ) it asking for component QT missing and component Qt mobility ... i continue the installation but it doesn't work ??

    plz help


  • Moderators

    What do you need help about?



  • the help about how can i deploy an application to N97 and working ... all i need clear steps to deploy after development ... and I appreciate that





  • What OS are you using? Linux or Windows? On Linux it is a bit more complicated :)



  • It's windows ... the application works in Nokia simulator but my problem when i install it on the real mobile doesn't work ???
    and during i install sis on N97 asked for QT missing and component Qt mobility are missing ?



  • [quote author="pc king" date="1290321071"]and during i install sis on N97 asked for QT missing and component Qt mobility are missing ?[/quote]

    Sorry, some misunderstanding. Have you installed Qt and Qt Mobility on device? If you are using Nokia SDK then the corresponding shortcuts are available in the Start menu.

    Try to install demo that does not use Mobility (elasticnodes, for example) for more precision localization of the problem.



  • no i haven't install any thing on n97 ?? i thought it works without install qt ??



  • [quote author="pc king" date="1290344665"]no i haven't install any thing on n97 ?? i thought it works without install qt ?? [/quote]

    A Qt application won't work if your device does not have Qt libraries installed. Read the docs about deployment on Symbian in "Qt docs":http://doc.qt.nokia.com/4.7/deployment-symbian.html and "Symbian.org wiki":http://developer.symbian.org/wiki/Deploying_a_Qt_Application



  • [quote author="pc king" date="1290344665"]no i haven't install any thing on n97 ?? i thought it works without install qt ?? [/quote]

    I have no n97, so I am just guessing. On forums (do not remember exact place) I see that Qt on device should be exactly the same as used for compilation (probably the same binaries, not just version number).

    So, if Qt is already pre-installed on your phone then try to find the corresponding development package on Nokia's site. If Qt is not pre-installed then you should load it into device as described in the documentation. See Links to the documentation above in the post from anselmolsm.



  • All the devices older than the Symbian^3 ones (N8, E7, C7, C6-01) do not have Qt installed by default. For those cases, consider using the smart installer (it is one of the Ovi Store requirements, BTW).


Log in to reply