[SOLVED] Qt Creator 2.6 on QT5 Source



  • Hello,

    Build the latest Qt Creator 2.6 master against the latest QT5 master I get :

    ERROR: Unknown module(s) in QT: quick1

    From :

    cd qmleditorwidgets/ && ( test -f Makefile ||'LOCALDIRREPLACED'/qt5/qtbase/bin/qmake 'LOCALDIRREPLACED'/qt-creator/src/libs/qmleditorwidgets/qmleditorwidgets.pro -spec linux-clang -o Makefile ) && make -f Makefile

    Tested :

    • Replaced quick1 by qml, it request link to qdeclarative.h which is in qtquick1
    • Replaced quick1 by quick, it request link to qdeclarative.h which is in qtquick1
    • Replaced quick1 by qtquick1, give Project ERROR: Unknown module(s) in QT: qtquick1

    Can you please advice on the point to adapt or investigate ?


  • Moderators

    Please file a bug report. That will end up with the guy that broke the build system:-)



  • Thank you.

    I hope the error is mine and not a bug.

    https://bugreports.qt-project.org/browse/QTCREATORBUG-7629


  • Moderators

    Don't worry.

    I took the liberty of assigning it over to our qmake expert, so I am sure that you will get a friendly note telling you in detail why you should not touch a computer ever again if this is not a real bug:-)



  • Arg ... I just begin a meteoric career in software development ... I might end too quickly exploded


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.