Error including Qt3D header files while trying to build Qt3D



  • Hello,
    I am new to Qt, i've only made some very simple projects with basic OpenGL to try the Creator a bit, so my experience is very small on this matter.
    I am running Windows 7 Home Premium 64Bit, with Microsoft Visual Studio 2010 Premium installed.
    I Downloaded and installed the QtSDK package with the offline installer (checked for updates after but there were none available).
    I am using Qt v4.8.1, and have my building configuration to use MSVC2010 (Qt SDK).
    After getting the Qt4 folder of Qt3D from https://qt.gitorious.org/qt/qt3d/trees/qt4, i try to build it on the Qt Creator, but after some time it will break and give me the error message:
    (...)\qt-qt3d\src\quick3d\qdeclarativeeffect.h:53: error: C1083: Cannot open include file: 'qgltexture2d.h': No such file or directory

    I've tried changing some of the build configs, but most of the times there were no changes on the compilation output, then after googling a lot i've seen a post related to this and i saw where this files were and figured that if changed for example "qgltexture2d.h" to "Qt3D/qgltexture2d.h" it would not give any error there, and i even tried doing that in all the files being included from the Qt3D folder (in my case is "C:\QtSDK\Desktop\Qt\4.8.1\msvc2010\include\Qt3D"), but after passing those files, it would result in a LINK error caused by the lack of the library Qt3DQuick.dll.
    I dont know what exacly is causing this problem, i thought that it could be some misconfigured setting that caused the build process not to be including correcly the header files in the Qt3D folder but i since i don't have any experience with Qt and this building process, i don't know where to start, i've tried googling this problem in a lot of ways but never found anyone else with this problem, so i assume i'm doing something wrong...
    Can anyone explain to me what i'm doing wrong?
    And sorry for the big long post but i wanted to give in all the detailed info that might be needed.

    Best regards

    PS: Sorry for any typos in my spelling.



  • After some more tries, i've managed to resolve the problem with the failure to include the Qt3D files while building quick3d adding the following to my quick3d.pro file:
    INCLUDEPATH += C:\QtSDK\Desktop\Qt\4.8.1\msvc2010\include\Qt3D

    Problem now is that apparently the dll file is not being created and o now get the error:

    LNK1120: 94 unresolved externals
    File not found: c:\QtSDK\Desktop\Qt\4.8.1\msvc2010\lib\Qt3DQuick.dll

    this error is followed by many others, that arise from the failure to load this library i suppose since all the following errors are unresolved external errors.

    Anyone has any idea on why the dll file is not being created?
    All help would b greatly appreciated,

    Best regards,

    Helder Santos


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.