Important: Please read the Qt Code of Conduct -

Qt5 QtWebKit build

  • Hi,

    I tried to build Qt5 and QtWebKit but I failed to build QtWebKit with the following errors.

    Project WARNING: Use load(qt_build_config) instead of load(qt_module).
    Project WARNING: /home/ewlee/qt5/qtwebkit/Source/api.pri still sets MODULE_PRI. Not auto-generating module .pri file.
    Project WARNING: Could not resolve QMAKE_EXTRA_MODULE_FORWARDS path!
    Project ERROR: Unknown module(s) in QT: declarative
    make[2]: *** [sub-api-pri-make_first-ordered] Error 2
    make[2]: Leaving directory /home/ewlee/qt5/qtwebkit/WebKitBuild/Release/Source' make[1]: *** [sub-Source-QtWebKit-pro-make_first-ordered] Error 2 make[1]: Leaving directory/home/ewlee/qt5/qtwebkit/WebKitBuild/Release'
    make: *** [incremental] Error 2

    I followed but I couldn't succeed to build qtwebkit.
    I couldn't find out any clue or solution from this site so I am posting new topic.
    Can anybody help me?

  • Moderators

    This is not your fault. "declarative" module name was changed to "quick1". Try again in a few days - update your local clone and rerun the compilation. Or, you can try checking out QtWebKit's HEAD right now, maybe it is fixed there already.

  • Thanks for reply.

    I checked out HEAD and rebuilt qtwebkit but the problem was not gone.
    How can I check whether or not I checked out qtwebkit's HEAD?

  • Moderators

    You can use qt5_tool, but you will have to consult "Building Qt5 from Git" for that, I don't remember the syntax.

    cd qtwebkit
    git pull
    cd ..
    ./build -j <number of cores>

    Not sure if pull will work. If not, you can try using git fetch, then decide which branch is the newest (might be master, but might have some other name).

  • I checked qtwebkit's branch and it was master.
    Origin/master is origin/HEAD, which means HEAD qtwebkit didn't solve this error.
    Do you know how to fix this error?
    The only thing I can do is waiting for a few days and retry it?

  • Moderators

    Probably yes. Or you can attempt to fix this yourself, and submit a patch to Qt devs :) You can also try checking out some older SHA from qt5.git, or grab sources/ binaries from "Qt5 snapshots":

  • I have tried to cross build latest snapshot and with some work I have manged to get into WebKit compilation. It was doing quite well for a moment until I got to point:

    in dir: /qtwebkit/WebKitBuild/Release/Source/WebKit2

    Project ERROR: Unknown module(s) in QT: quick qml

    Those modules are specified in Target.pri and WebKit2.pri but I seem to not have them? There is qtquick1 but it seems it depends on webkit to be build first so I always get back to same error.

  • I tried to build qtwebkit and finally I succeeded to do that.
    However, I got another issue like below when I run MiniBrowser in qtwebkit.
    QXcbConnection: Failed to initialize XRandr
    QXcbConnection: Failed to initialize XFixes
    QXcbConnection: Failed to initialize XRender
    Xcb packages are installed correctly and libxcb version is 1.8.
    Do you have any suggestions for this problem?

    BTW, I can not use eglfs qpa platform instead of xcb?

  • For more information, I already tried to add directfb or opengl as a qpa platform when I did ./configure with -directfb -opengl.
    But it was not applied and only xcb platform was built.
    How can I configure it?

Log in to reply