Opening projects in QT creator

  • Hi,
    Apologise if this is a newbie question, but I've googled and tried everything to no avail. If you could give me some tips and pointers it would save me hours of stuffing around.

    I'm trying to open and compile a project in QT creator. The file (as I believe) is compiled using cmake as it has no main.cpp file. It has a CMakeLists.txt file. I've installed cmake and I try to open the project by trying to open the cmakelists.txt file.

    I specify the directory for the build location, and then I'm taken to the "Run Cmake" screen. If I click on "Run Cmake", the button blanks out and nothing happens.

    I've also tried going the other route, using cmake, mingw (standalone installation), but I get stuck because the project I need to compile requires iniparser, which I cannot have since I'm running windows.

    If anyone can give me some tips to get me started, it would be much appreciated. Thanks guys.

  • Moderators

    welcome to devnet

    For getting you started with Qt creator it would be probably better to open one of the examples delivered typically part of the distributions. They have already everything in good shape.

    There are also some tutorials for handling creator available. Follow "this link.":

  • Thanks for replying.

    I've actually already had a look at some QML files and sample projects and i've been able to go through them OK. The problem is the project i'm working on, which is something that I need to modify and customise to do what we want. Unfortunately they don't use the standard format which i'm used to (no main.cpp file, nor qml file as per Qt, but a cmakelists.txt file), even though it's meant to have been developed in Qt.

    Do you know how one goes about opening and compiling such a project? I'm getting stuck at "run cmake".

  • Ah, I found the problem. Just needed to reinstall qt (took ages, but eventually worked). Now still having some errors but at least I know what they are. Thanks all.

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.