QtQuick 1.0 with opengl support?



  • Hello together,

    we tried the "HomeControl" demo (http://www.youtube.com/watch?v=23qJoxQEvVg) for Qt Quick on a Embedded device and it seems to be very slow. Now we got the idea to use opengl by enable the option -graphicssystem opengl.

    Is opengl really working for Qt Quick 1.0? As i could read will be the opengl support enabled in Qt Quick 2.0 and is not existing.

    When i enable the graphicsystem opengl i got the error message "Unable to load graphicssystem "opengl""....Does anybody know howto solve it?

    Greetings

    Torsten



  • You should be able to do what you are describing, provided that your Qt build was configured to use the opengl graphicssystem. Sounds like that might be the problem.

    Alternatively, you could use a QGlWidget as viewport for the declarative view.



  • Here are my configure options. Is there everthing in or is there some option missing for opengl support in Qt 4.7.2?

    @./configure
    -verbose
    --force-pkg-config
    -no-separate-debug-info
    -prefix /usr
    -hostprefix $(STAGING_DIR)/usr
    -fast
    -no-rpath
    -nomake examples
    -nomake demos
    -opensource -confirm-license
    -platform linux-g++
    -arch linux-g++
    -xplatform qws/linux-x86-g++
    -xplatform qws/linux-x86-g++
    -no-pch
    -qt3support
    -no-openssl
    -no-webkit
    -no-multimedia
    -no-phonon
    -no-cups
    -no-nas-sound
    -no-scripttools
    -qt-zlib
    -qt-gif
    -qt-libtiff
    -qt-libpng
    -qt-libmng
    -qt-libjpeg
    -xmlpatterns
    -svg
    -qt-sql-sqlite@



  • I could solve this problem:

    When i enable the graphicsystem opengl i got the error message “Unable to load graphicssystem “opengl”“….Does anybody know howto solve it?

    I forgot to copy the /usr/plugins/ to my target. Now i do not get this error, but the performance for the home control demo is still very bad.



  • To be able to use the opengl graphicssystem, I would assume that you would need to pass the '-graphicssystem opengl' option to configure. And probably also '-opengl es1' or '-opengl es2' to specify the version of OpenGL ES to use. But maybe those get set to suitable values by default.



  • I still make no performance difference in Qt 4.7.2 i will try this with Qt5 now



  • Is there any way to test the that opengl is really used by declarative view? I allready took another opengl demo from qt (pathstroke). This one runs very well on it.



  • Are you using the -graphicssystem option or a QGlWidget as viewport? Or both?



  • i use this command: ./smarthome -graphicssystem opengl -opengl es2
    i use this demo http://qt-project.org/wiki/Home_Control_Demo
    with Qt 4.7.2 on Linux X11

    Thx for your help!!



  • OK, but I don't think you can use '-opengl es2' as an option to the application, it is a configure option. '-graphicssystem opengl' happens to be both a configure option and an application option.
    And to be able to use a QGlWidget as viewport, you'll have to modify the C++ source code.



  • At the moment i do create the Qml Viewer like this:

    @ QmlApplicationViewer viewer;
    viewer.setOrientation(QmlApplicationViewer::ScreenOrientationLockLandscape);
    viewer.setMainQmlFile(QLatin1String("qml/smarthome/smarthome.qml"));
    viewer.show();@

    Could you give me a help what i have to do different?

    Thx



  • Haven't used the QmlApplicationViewer, so I don't know how to do that, sorry. I assume you would have to change the QmlApplicationViewer source code, where the declarative view is created. Just create a QGlWidget, and set it as the declarative view's viewport. You may also have to adjust its QGlFormat to something suitable for your device.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.