Qt installation in Linux



  • Hi,
    I am very new to Qt framework and trying to install QTSDK on a 64-bit Linux machine. I downloaded the QtSdk-offline-linux-x86_64-v1.2.1.run file and when I tried to run it, it shows me the following error:

    ./QtSdk-offline-linux-x86_64-v1.2.1.run
    ./QtSdk-offline-linux-x86_64-v1.2.1.run: /usr/lib64/libstdc++.so.6: version GLIBCXX_3.4.9’ not found (required by ./QtSdk-offline-linux-x86_64-v1.2.1.run) ./QtSdk-offline-linux-x86_64-v1.2.1.run: /usr/lib64/libstdc++.so.6: versionGLIBCXX_3.4.11’ not found (required by ./QtSdk-offline-linux-x86_64-v1.2.1.run)
    ./QtSdk-offline-linux-x86_64-v1.2.1.run: /lib64/libc.so.6: version GLIBC_2.9’ not found (required by ./QtSdk-offline-linux-x86_64-v1.2.1.run) ./QtSdk-offline-linux-x86_64-v1.2.1.run: /lib64/libc.so.6: versionGLIBC_2.10’ not found (required by ./QtSdk-offline-linux-x86_64-v1.2.1.run)
    ./QtSdk-offline-linux-x86_64-v1.2.1.run: /lib64/libc.so.6: version GLIBC_2.11’ not found (required by ./QtSdk-offline-linux-x86_64-v1.2.1.run) ./QtSdk-offline-linux-x86_64-v1.2.1.run: /lib64/libc.so.6: versionGLIBC_2.7’ not found (required by ./QtSdk-offline-linux-x86_64-v1.2.1.run)

    My system has glibc2.4 and libstdc++3.4.8. Is it possible to install Qt framework on linux without updating the glibc and glic++ libraries, even using an older version of the QT?

    Another Question: Is it possbile to use only the qt-libraries to generate the GUIs withour installing the full SDK?

    Thanks.



  • Hello,

    as i know qt 4.7 or higher needs the gcc 4.4....

    maybe you could take an older qt version?

    I guess to create you own Qt apps you need to install it. Which linux do you use? Which Qt Version do you use?



  • bq. Another Question: Is it possbile to use only the qt-libraries to generate the GUIs withour installing the full SDK?

    Install Qt and Qt Creator from your Linux distributions package manager.
    SDK contains both and toolchains for mobile targets.



  • Thanks for the replies.
    The Qt version I am trying to install is 4.8. the gcc version on my system is 4.2.4. The linux version info is:
    SUSE Linux Enterprise Server 10 (x86_64)
    VERSION = 10
    PATCHLEVEL = 3
    LSB_VERSION="core-2.0-noarch:core-3.0-noarch:core-2.0-x86_64:core-3.0-x86_64".
    Can you please tell me which Qt version will be OK with my system configuration?

    Tomma: How can I install  Qt from my linux distribution? I have the installer but it gives me the glic error.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.