Use Solaris studio 12.3 in Redhat



  • Hi,
    Does anyone know the download package of Qt that is applicable to Solaris studio C++ 12.3?

    Many Thanks & Best Regards,
    HuaMin


  • Moderators

    If there is none in the repo, you can always download and install from source or SDK.



  • Thanks. I run Solaris studio 12.3 in Redhat and am unsure which Qt library should be attached/applied to either my application or studio package?

    Many Thanks & Best Regards,
    HuaMin


  • Moderators

    The newest one, probably (4.8.2)? I don't use RedHat, but I think they should have something in the repo. I don't use Solaris Studio, either, so I don't even quite understand your problem here. You can install Qt globally and then any compiler/ linker/ IDE should pick it up without problems, just as any other lib.



  • Hi,
    After I’ve extracted the download, I got this
    qt-everywhere-opensource-src-4.8.2

    how to make use of libraries of that, as when I tired to put this in my app
    #include <QDialog>

    I’ve got this.
    "main.cpp", line 10: Error: Could not open include file<QDialog>.

    Many Thanks & Best Regards,
    HuaMin


  • Moderators

    Mate, please use documentation and Google before posting. Also, or rather first, take a look at readme files inside the package you have downloaded.

    You need to configure, compile and then install the libraries, before they are ready to use. That is why installing the SDK is a bit easier. You might need to update your PATH, too, so that your build chain is able to see the headers and libs.



  • For the SDK, I’ve got one file called “QtSdk-offline-linux-x86-v1.2.1.run” from Qt. How to set it up in Redhat?

    Many Thanks & Best Regards,
    HuaMin


  • Moderators

    Set it to executable and simply run. In terminal, this would look like this:
    @
    chmod +x QtSdk-offline-linux-x86-v1.2.1.run
    ./QtSdk-offline-linux-x86-v1.2.1.run
    @



  • Sorry I do get this
    [root@hpi5 ~]# chmod +x QtSdk-offline-linux-x86-v1.2.1.run
    [root@hpi5 ~]# ./QtSdk-offline-linux-x86-v1.2.1.run
    ./QtSdk-offline-linux-x86-v1.2.1.run: /usr/lib/libstdc++.so.6: version GLIBCXX_3.4.9' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run) ./QtSdk-offline-linux-x86-v1.2.1.run: /usr/lib/libstdc++.so.6: versionGLIBCXX_3.4.11' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run)
    ./QtSdk-offline-linux-x86-v1.2.1.run: /lib/libc.so.6: version GLIBC_2.9' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run) ./QtSdk-offline-linux-x86-v1.2.1.run: /lib/libc.so.6: versionGLIBC_2.10' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run)
    ./QtSdk-offline-linux-x86-v1.2.1.run: /lib/libc.so.6: version GLIBC_2.11' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run) ./QtSdk-offline-linux-x86-v1.2.1.run: /lib/libc.so.6: versionGLIBC_2.7' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run)
    [root@hpi5 ~]#


  • Moderators

    Install or update glibc. You have to take care of dependencies.



  • Good day Sierdzio,
    After I’ve set up glibc, like these
    [root@hpi5 ~]# yum install glibc*
    Loaded plugins: rhnplugin, security
    This system is not registered with ULN.
    ULN support will be disabled.
    Setting up Install Process
    Package glibc-devel-2.5-81.el5_8.2.i386 already installed and latest version
    Package glibc-2.5-81.el5_8.2.i686 already installed and latest version
    Package glibc-headers-2.5-81.el5_8.2.i386 already installed and latest version
    Package glibc-utils-2.5-81.el5_8.2.i386 already installed and latest version
    Package glibc-common-2.5-81.el5_8.2.i386 already installed and latest version
    Nothing to do
    [root@hpi5 ~]#

    Why do I still get these?
    [root@hpi5 ~]# chmod +x QtSdk-offline-linux-x86-v1.2.1.run
    [root@hpi5 ~]# ./QtSdk-offline-linux-x86-v1.2.1.run
    ./QtSdk-offline-linux-x86-v1.2.1.run: /usr/lib/libstdc++.so.6: version GLIBCXX_3.4.9' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run) ./QtSdk-offline-linux-x86-v1.2.1.run: /usr/lib/libstdc++.so.6: versionGLIBCXX_3.4.11' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run)
    ./QtSdk-offline-linux-x86-v1.2.1.run: /lib/i686/nosegneg/libc.so.6: version GLIBC_2.9' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run) ./QtSdk-offline-linux-x86-v1.2.1.run: /lib/i686/nosegneg/libc.so.6: versionGLIBC_2.10' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run)
    ./QtSdk-offline-linux-x86-v1.2.1.run: /lib/i686/nosegneg/libc.so.6: version GLIBC_2.11' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run) ./QtSdk-offline-linux-x86-v1.2.1.run: /lib/i686/nosegneg/libc.so.6: versionGLIBC_2.7' not found (required by ./QtSdk-offline-linux-x86-v1.2.1.run)
    [root@hpi5 ~]#

    Many Thanks & Best Regards,
    HuaMin



  • Good day Sierdzio,
    Any advice to this?

    Many Thanks & Best Regards,
    HuaMin


  • Moderators

    Sorry, no clue. I am on Kubuntu and here everything works fine.



  • Can you please see my issue? Is this site the only place to take Qt?

    Many Thanks & Best Regards,
    HuaMin


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.