I’m unable to build via Qt Creator



  • Hello i'm completly new to Qt and so i have no clue what could be possebly lead to the following error when i try to build A DEMO as an example to beginn with.

    That's what the compiler says:
    jom:
    @22:14:51: Führe Build-Schritte für Projekt analogclock aus...
    22:14:51: Unveränderte Konfiguration, qmake-Schritt wird übersprungen.
    22:14:51: Starte "C:\QtSDK\QtCreator\bin\jom.exe"
    C:\QtSDK\QtCreator\bin\jom.exe -nologo -j 4 -f Makefile.Debug
    cl -c -nologo -Zm200 -Zc:wchar_t- -Zi -MDd -GR -EHsc -W3 -w34100 -w34189 -DUNICODE -DWIN32 -DQT_LARGEFILE_SUPPORT -DQT_DLL -DQT_GUI_LIB -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_THREAD_SUPPORT -I"........\Desktop\Qt\4.8.1\msvc2010\include\QtCore" -I"........\Desktop\Qt\4.8.1\msvc2010\include\QtGui" -I"........\Desktop\Qt\4.8.1\msvc2010\include" -I"........\Desktop\Qt\4.8.1\msvc2010\include\ActiveQt" -I"debug" -I"..\analogclock" -I"." -I"........\Desktop\Qt\4.8.1\msvc2010\mkspecs\win32-msvc2010" -Fodebug\ @C:\Users\ADMINI~1\AppData\Local\Temp\analogclock.obj.5020.16.jom
    cl -c -nologo -Zm200 -Zc:wchar_t- -Zi -MDd -GR -EHsc -W3 -w34100 -w34189 -DUNICODE -DWIN32 -DQT_LARGEFILE_SUPPORT -DQT_DLL -DQT_GUI_LIB -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_THREAD_SUPPORT -I"........\Desktop\Qt\4.8.1\msvc2010\include\QtCore" -I"........\Desktop\Qt\4.8.1\msvc2010\include\QtGui" -I"........\Desktop\Qt\4.8.1\msvc2010\include" -I"........\Desktop\Qt\4.8.1\msvc2010\include\ActiveQt" -I"debug" -I"..\analogclock" -I"." -I"........\Desktop\Qt\4.8.1\msvc2010\mkspecs\win32-msvc2010" -Fodebug\ @C:\Users\ADMINI~1\AppData\Local\Temp\main.obj.5020.47.jom
    cl -c -nologo -Zm200 -Zc:wchar_t- -Zi -MDd -GR -EHsc -W3 -w34100 -w34189 -DUNICODE -DWIN32 -DQT_LARGEFILE_SUPPORT -DQT_DLL -DQT_GUI_LIB -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_THREAD_SUPPORT -I"........\Desktop\Qt\4.8.1\msvc2010\include\QtCore" -I"........\Desktop\Qt\4.8.1\msvc2010\include\QtGui" -I"........\Desktop\Qt\4.8.1\msvc2010\include" -I"........\Desktop\Qt\4.8.1\msvc2010\include\ActiveQt" -I"debug" -I"..\analogclock" -I"." -I"........\Desktop\Qt\4.8.1\msvc2010\mkspecs\win32-msvc2010" -Fodebug\ @C:\Users\ADMINI~1\AppData\Local\Temp\moc_analogclock.obj.5020.78.jom

    jom 1.0.6 - empower your cores

    Der Befehl "cl" ist entweder falsch geschrieben oder
    konnte nicht gefunden werden.
    command failed with exit code 1
    Der Befehl "cl" ist entweder falsch geschrieben oder
    konnte nicht gefunden werden.
    command failed with exit code 1
    Der Befehl "cl" ist entweder falsch geschrieben oder
    konnte nicht gefunden werden.
    command failed with exit code 1
    command failed with exit code 2
    22:14:52: Der Prozess "C:\QtSDK\QtCreator\bin\jom.exe" wurde mit dem Rückgabewert 2 beendet.
    Fehler beim Erstellen des Projekts analogclock(Ziel: Desktop)
    Bei der Ausführung von Build-Schritt 'Make'@

    nmake:
    @22:15:30: Führe Build-Schritte für Projekt analogclock aus...
    22:15:30: Unveränderte Konfiguration, qmake-Schritt wird übersprungen.
    22:15:30: Starte "nmake.exe"
    qtcreator_ctrlc_stub: Command line failed: nmake.exe
    22:15:30: Der Prozess "nmake.exe" ist abgestürzt.
    Fehler beim Erstellen des Projekts analogclock(Ziel: Desktop)
    Bei der Ausführung von Build-Schritt 'Make'@

    i would be grateful to recive a solution for the problem. What i have done wrong while the setup?


  • Moderators

    welcome to devnet

    This looks like there is a problem with the path to the msvc compiler. jom complains that "cl" is not found. Apparently "nmake" is not found at all by qt creator. You need to check the settings to the tool chain.

    Can you use mingw with qt creator?
    Mingw comes with qt creator and has probably less problems to start with. You may change to msvc tool chain afterwards.



  • Thank you for helping. Well mingw does his jop after the compiling the simulator poped-up the programm runs. So it must be as you first guessed the toolchain.
    Here is a picture of the settings:

    http://imageshack.us/photo/my-images/822/toolchain.png/

    A you can see it seems to be the case that the path is already set.....wrong ?
    What would be the right configuration?


  • Moderators

    Unfortunately, I have no experience with Qt creator and MSVC as tool chain. I use msvc 2005 including its IDE or I have installed qt creator with mingw, but the latter one is more or less installed only.

    However, there are some threads dealing with the issues of using msvc as tool chain for qt creator.
    You need to dig through those
    "first":http://qt-project.org/forums/viewthread/9528/
    "second":http://qt-project.org/forums/viewthread/6522/

    I have found those with advanced search with "msvc2010 tool chain" as parameters.

    Furthermore I will move your thread to "tools". Typically there are the threads with creator discussed.



  • Ok thank you mate I solved the problem by reinstalling the QtSDK and delete all MSVC Toolchain-links and used mingw desktop instead.

    Also thank you for your search of relevant topics i didn't knew about. If I have the time and the passion I will try to fix the MSCV thing.


  • Moderators

    You are welcome.
    However, I did not mean to drag you away from using msvc as tool chain. However, my feel is it might be a tedious thing to get it go, so I have avoided so far.
    If you have a licensed version of msvc you may want to use also the IDE of msvc together Qt. However, an express version will not do, since it is probably better also to use vsaddin which requires a full version of msvc.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.