[Closed] Qt Creator's MSVC2010 debug compiler didn't work with OpenCV in Windows system



  • But MSVC2010 release compiler works well with OpenCV.I don't know why.
    Here's part of my .pro file.

    @INCLUDEPATH +=D:\OpenCV\opencv\build\include\opencv2
    D:\OpenCV\opencv\build\include\opencv
    D:\OpenCV\opencv\build\include

    CONFIG(release,debug|release)
    {
    LIBS += D:\OpenCV\opencv\build\x86\vc10\lib\opencv_calib3d231.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_contrib231.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_core231.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_features2d231.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_flann231.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_gpu231.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_highgui231.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_imgproc231.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_legacy231.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_ml231.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_objdetect231.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_ts231.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_video231.lib
    }

    CONFIG(debug,debug|release)
    {
    LIBS +=D:\OpenCV\opencv\build\x86\vc10\lib\opencv_calib3d231d.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_contrib231d.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_core231d.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_features2d231d.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_flann231d.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_gpu231d.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_highgui231d.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_imgproc231d.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_legacy231d.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_ml231d.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_objdetect231d.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_ts231d.lib
    D:\OpenCV\opencv\build\x86\vc10\lib\opencv_video231d.lib
    }@

    Thank you for your attention.


  • Moderators

    There is "no need to create double postings":https://qt-project.org/forums/viewthread/17152/
    Closing this thread here.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.