GLIBCXX_3.4.9 problem



  • Hi everyone,

    I have an error just before finishing the installation. So what I write here:

    "Problem running post-install step. Installation may not complete correctly.
    Error running /opt/qtsdk-2010.05/bin/qpatch
    '/opt/qtdsk-2010.05/bin/files-to-patch-linux'
    '/home/berlin/dev/qt-4.7.0-opensource-shipping/this_path_is_supposed_to_be_very_long_hopefully_this_is_long_enough/qt'
    '/opt/qtsdk-2010.05/qt' : /opt/qtsdk-2010.05/bin/qpatch: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /opt/qtsdk-2010.05/bin/qpatch)"

    And when I run the program shows a similar error:
    "Failed to load core:
    /opt/qtsdk-2010.05/lib/qtcreator/plugins/Nokia/libCore.so:
    Cannot load library /opt/qtsdk-2010.05/lib/qtcreator/plugins/Nokia/libCore.so:
    (/lib/libstdc++.so.6:
    version `GLIBCXX_3.4.9' not found (required by /opt/qtsdk-2010.05/lib/qtcreator/plugins/Nokia/../../libBotan.so.1) )"

    If there is a forum thread that addresses the same subject tell me the links, please, because I did not find it.

    Thanks and regards.



  • I forgot to mention I am using is Red Hat Enterprise Linux 5.5 and I am installing QT 2.0.1 Creator.

    Thanks.



  • why the QT officer not response? shit!



  • Most of the writers in this forum are volunteers, answering in their spare time. Offending them will definitely not help getting an answer.


  • Moderators

    My guess is that the libstdc++ on your system is too old for the packages. If there is no newer package available then you will need to build Qt Creator from sources.

    Of course you could also consider to upgrade your OS to something with a more recent C++ environment. My guess is that Qt Creator will not be the only application relying on a recent C++ environment, so you will run into this issue again sooner or later.



  • Thank you all for your help.

    Finally I solved the problem when I installed an older version:
    "Qt Creator 2.0.1
    Based on Qt 4.7.0 (32 bit)

    Built on Aug 30 2010 at 20:43:41 "

    But now I have another problem.
    I'm trying to run the example "Hello World" and I have the following error:

    "Running for project build steps hellotr ...
    Starting "/ usr / bin / make" clean-w
    make: Entering directory / opt/qtsdk-2010.05/qt/examples/linguist/hellotr-build-desktop ' rm-f main.o rm-f * ~ core *. core make: Leaving directory/ opt/qtsdk-2010.05/qt/examples/linguist/hellotr-build-desktop '
    The process "/ usr / bin / make" exited normally.
    Configuration Unchanged, skipping qmake step.
    Starting "/ usr / bin / make-w
    make: Entering directory / opt/qtsdk-2010.05/qt/examples/linguist/hellotr-build-desktop ' g + +-c-pipe-O2-Wall-W-D_REENTRANT-DQT_NO_DEBUG-DQT_GUI_LIB-DQT_CORE_LIB-DQT_SHARED -I../../../mkspecs/linux-g + +-I ../.. -I../hellotr / .. / include / QtCore -I../../../include/QtGui -I../../../include-I. -I../hellotr-I. -O main.o .. / hellotr / main.cpp g + +-Wl,-O1-Wl,-rpath, / opt/qtsdk-2010.05/qt/lib-o main.o -L/opt/qtsdk-2010.05/qt/lib hellotr -L/opt/fontconfig-2.4.2 -lQtGui -L/opt/qtsdk-2010.05/qt/lib-lpthread -L/usr/X11R6/lib-lQtCore / Opt/qtsdk-2010.05/qt/lib/libQtGui.so: undefined reference toFcFreeTypeQueryFace '
    collect2: ld returned 1 exit status
    make: *** [hellotr] Error 1
    make: Leaving directory `/ opt/qtsdk-2010.05/qt/examples/linguist/hellotr-build-desktop '
    The process "/ usr / bin / make" exited with code% 2.
    Error while building project hellotr (target: Desktop)
    When executing build step 'Make' "

    I have seen this error is more common than the last but I managed to fix it
    Could you tell me a link where this error is already resolved?


  • Moderators

    FCFreeTypeQueryFace is most likely a symbol from freetype. You should make sure you have the freetype library installed. If you do you might want to consider upgrading the freetype library to a more current version.

    PS: It might be a good idea to open a new thread for the new issue.



  • Red Hat 5 ships some quite old software. And it is rather server oriented distribution. You should consider changing it to other one (probably Fedora will be good choice for you, as it's Red Hat based desktop distro). Many other distributions have both Qt and QtCreator in their repositories, so everything should work out of the box. If you want to stay with RH, try to upgrade it to version 6 at first.



  • At work we use SLES 10 enterprise. It also has this issue so I can't use QT which is a shame. It would be great to have a way of getting round it as upgrading the OS is not an option.

    Is there really no other way around this issue ?



  • Compiling everything yourself is always a second option - not really convenient, though, but saves you an OS upgrade :-)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.