[Solved] App Icon vanished after moving Qt 4.8.x and projects from Mac OS 10.6 to 10.7



  • I have been developing Qt projects under Mac OS 10.6.x for two years. I use QtCreator IDE. Adding macx:ICON=<path_to_icon> to .pro file has always been enough to provide an icon for the resulting app (application bundle).

    However, after upgrading to Mac OS 10.7.3 (Lion) and installing new xCode I have found that although the Qt projects are successfully compiled and ran, application icon is never added.

    Eventually, Info.plist file and the icon are not copied into <compiled application>.app/Contents/Resources/. However, when looking through the automatically generated Makefile, I find all the directives intended to perform the copying.

    I have tried a standard workaround adding macx:QMAKE_INFO_PLIST = MyCustomInfo.plist into .pro file and writing the MyCustomInfo.plist manually. Unfortunately, it did not work.

    I have tried completely erasing and reinstalling xCode and Qt SDK (v1.2 with Qt 4.8.0 and v.1.2.1 with Qt 4.8.1). It did not help either.

    Did anybody face similar problems? Do you have any ideas where to look for solution?

    Thank you in advance for your suggestions...

    [UPDATE: THE ISSUE IS SOLVED]
    For some reason the icon was not added into Mac OS App if build was performed in a separate directory nested on the same level with .pro file. In case build is run in .pro file directory everything goes smooth. Despite Qt warnings when you build project in a directory nested above .pro file everything also goes O.K.

    Mac OS 10.7.3 (Lion), Qt 4.8.0, Qt 4.8.1


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.