Qt5.0.0 mingw compile problem



  • Hello.
    I'm trying to compile qt5 with mingw but I have a problem.

    configuration:
    configure -release -opensource -confirm-license -nomake tests -prefix e:\qt5\qtbase -nomake demos -nomake examples

    build environment:
    SET QTDIR=E:\qt5\qtbase
    SET MINGWDIR=E:\MinGW
    SET QMAKESPEC=win32-g++
    SET PERLDIR=E:\IDE\strawberry\perl
    SET PYTHON=E:\IDE\Python27

    SET PATH=%QTDIR%\bin;%MINGWDIR%\bin;%SystemRoot%\System32;%PERLDIR%\bin;%PYTHON%\

    The problem is
    !http://img18.imageshack.us/img18/8527/snag0167.png(Problem)!

    Here is the command that cause a crash (length 8504 but cmd allows 8191):
    http://paste.org/47708

    How I can solve this problem?



  • In Visual Studio can't build too
    !http://img337.imageshack.us/img337/2210/snag0169.png(compile error)!



  • Forget MinGW, let's head over MSVC2010 and assuming you are working under MSVC2010

    Do the following:

    Start (Menu) => All Programs (Menu) => Microsoft Visual Studio 2010 (Folder) => Visual Studio Tools (Folder) => Visual Studio Command Prompt (2010) (File)

    Open Visual Studio Command Prompt (2010) and apply:

    @vcvarsall.bat@ (Type it then hit {[Enter]})

    The above command will configure the correct environment settings for compiling Qt under MSVC2010 and not MinGW GCC 4.4

    In that very same CMD type:
    @configure [-platform win32-msvc2010] -static -release -opensource -confirm-license -nomake tests -prefix e:\qt5\qtbase -nomake demos -nomake examples@

    RED = Optional, This will make a static build of Qt, This will make Standalone Executables if you like (That's why I added this optional statement.)

    NOTE: Notice the option added between the [ & ], This option will enable the compiling under MSVC2010 and configure the qmake to build and use MSVC2010 Correctly... Notice as well that for this to work you HAVE to remove the [ & ] symbols, I just added them for sake of observation.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.