Unable to detect Windows debugging tools



  • Hi,

    I'm trying to debug my projects with the native windows debugging tools. I have Qt Creator 2.4.1, VS2010 and the new Windows 8 SDK preview debugging tools (the only debugging tools available atm?).

    When trying to debug the program, I just get a message about not being able to detect the preferred debugger engine for debugging binaries of type x86-windows-msvc2010-pe-32bit.

    Any ideas?


  • Moderators

    Windows 8 SDK moved things around once again. Please try the upcoming 2.5 version of Qt Creator (I think support is there, it definitely is in master;-), that will pick up the debugger.



  • Ok, so there is no way to set up the paths manually?

    Is there a pre-built version of QtCreator 2.5 somewhere?

    Will 2.5 require Qt 5.0 btw?


  • Moderators

    You can try to install the microsoft debugger tools separately. Those should get picked up just fine.



  • As far as I could see there is no standalone package for the debugger tools anymore. It's only the Win8 SDK:

    http://msdn.microsoft.com/en-us/windows/hardware/gg463009

    There is an option for installing only the debugging tools, which is what I did, but it is basically just to install the WinSDK package and uncheck all the other componets, as explained on the above webpage:

    "If you do not want an entire kit (WDK or SDK), you can install the Debugging Tools as a standalone component from the Windows SDK. In the installation wizard, select Debugging Tools, and clear other components that you don’t want."

    But are these paths really hardcoded into QtCreator? Shouldn't there be a configuration path to set these paths?


  • Moderators

    So far the path to the debugging tools was stable (we do look in a couple of places), so there was no need to have it configurable. Let's hope that they will stick with the current location for a while... then we do not need it configurable now either.

    Yes, I see that this is annoying for you, but we can not support 3rd party applications that were not even around at the time when we released Creator.



  • Oh, I'm not that annoyed :-) i'm just a bit surprised that it isn't configurable, at least through a config file. It wouldn't even have to be exposed in the GUI. I suppose it would have spared you for these kinds of problems when MS decides they want to move things about.

    Anyway, I'm really looking forward to2.5, especially the new refactoring stuff. Is there a planned release date yet?



  • I had the same problem ... and I simply created a link:

    Open a command prompt with admin rights

    cd "\Program Files"

    mklink /D "Debugging Tools for Windows (x86)" "C:\Program Files\WinDDK\7.1\Debuggers"

    Did this on a Vista x86 system and everything works like a charm. Of couse you need to adapt your paths and the link name depending on your installation and system. If you're running ol' XP, get the "junction" utility from "Windows Sysinternals":http://technet.microsoft.com/en-us/sysinternals/bb896768.aspx

    Happy debugging!

    Markus.



  • Thanks Markus. That worked and solved the issue. Great.
    I'm working with Qt 4.8 and Creator 2.4.1 on a Packard Bell Easynote 10.1 with Windows 8 and MSVC 2010 Express. I installed the 8.1 SDK and therefore had to link to "c:\Program Files\Windows Kits\8.1\Debuggers\x86".
    Cheers
    R.K.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.