Error coding system messages



  • Good day.

    Can i ask you for some assistant? I have some problem with encoding system messages. For some reason, it's start shows to me unread messages. I believe, it was caused by recompiling project by qmake. However, immediately after recompiling, bug did not show himself - only after reboot system it's all has start. It is remarkable, but it is clear that all problems only with one project - the same time which i have recompile.

    Many thanks in advance for your attention. Thank you.


  • Moderators

    Sorry, but I really do not get what you are trying to do and where you run into trouble.




  • Moderators

    With gcc we force the default (english) locale to avoid this and to actually get the messages in a well defined format that we can actually recognize. Do you happen to know how we could force MSVC to english? I am not really into windows:-(

    You can "jump to output" by right-clicking on the entry. That will take you to the compile output pane. Is the text readable there?



  • No, the text are also unreadable.

    I think problem is described in detail in this message:
    @Not one of the debuggers "Cdb engine" "Gdb engine" able to debug program type "x86-windows-msvc-2010-pe-64bit" are not configure correct.@


  • Moderators

    No, the message says that you can not debug applications since you do not have the MS debugging tools installed and has nothing to do with the text encoding in the compile output/build issues pane.

    Could you try setting creator to english? Does that force the MSVC compiler to english, too, fixing the compile output text?



  • Nope. Setting creator to english wasn't help.


  • Moderators

    Not really surprising that... I guess for best results you will need to install a english compiler...

    If you have the time you could also try to figure out where the encoding is screwed up and fix it:-) The MsvcParser should be a good place to start looking if you care to do this.

    I am afraid I can do little since I am not on windows and have no access to a non-english compiler.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.