Compile Qt 4.8.0 on Centos 5.6 64Bit - Webkit Error!!



  • Dear all,

    I am trying to compile qt.4.8.0 from scratch on the above mentioned os.

    To configure it I use the following command:

    ./configure -nomake demos -nomake examples

    Unfortunately I am not able to compile until the end as webkit gives me a compile error:

    cd src/3rdparty/webkit/Source/ && gmake -f Makefile.WebKit
    gmake[1]: Entering directory /home/rmjzettl/Desktop/freecad_libs_source/qt-everywhere-opensource-src-4.8.0/src/3rdparty/webkit/Source' /home/rmjzettl/Desktop/freecad_libs_source/qt-everywhere-opensource-src-4.8.0/bin/qmake -spec ../../../../mkspecs/linux-g++-64 -o Makefile.WebKit WebKit.pro gmake[1]: Leaving directory/home/rmjzettl/Desktop/freecad_libs_source/qt-everywhere-opensource-src-4.8.0/src/3rdparty/webkit/Source'
    gmake[1]: Entering directory /home/rmjzettl/Desktop/freecad_libs_source/qt-everywhere-opensource-src-4.8.0/src/3rdparty/webkit/Source' cd JavaScriptCore/ && gmake -f Makefile.WebKit gmake[2]: Entering directory/home/rmjzettl/Desktop/freecad_libs_source/qt-everywhere-opensource-src-4.8.0/src/3rdparty/webkit/Source/JavaScriptCore'
    /home/rmjzettl/Desktop/freecad_libs_source/qt-everywhere-opensource-src-4.8.0/bin/qmake -spec ../../../../../mkspecs/linux-g++-64 -o Makefile.WebKit JavaScriptCore.pro
    gmake[2]: Leaving directory /home/rmjzettl/Desktop/freecad_libs_source/qt-everywhere-opensource-src-4.8.0/src/3rdparty/webkit/Source/JavaScriptCore' gmake[2]: Entering directory/home/rmjzettl/Desktop/freecad_libs_source/qt-everywhere-opensource-src-4.8.0/src/3rdparty/webkit/Source/JavaScriptCore'
    g++ -c -m64 -pipe -Wall -Wextra -Wreturn-type -fno-strict-aliasing -Wcast-align -Wchar-subscripts -Wformat-security -Wreturn-type -Wno-unused-parameter -Wno-sign-compare -Wno-switch -Wno-switch-enum -Wundef -Wmissing-noreturn -Winit-self -Werror -fno-stack-protector -O3 -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -D_REENTRANT -DNDEBUG -DBUILDING_QT__=1 -DNDEBUG -DQT_ASCII_CAST_WARNINGS -DBUILDING_JavaScriptCore -DBUILDING_WTF -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DQT_NO_DEBUG -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_HAVE_SSE3 -DQT_HAVE_SSSE3 -DQT_SHARED -I../../../../../mkspecs/linux-g++-64 -I. -I../../../../../include/QtCore -I../../../../../include -I. -I../../Source -I../ThirdParty -Iassembler -Ibytecode -Ibytecompiler -Iheap -Idfg -Idebugger -Iinterpreter -Ijit -Iparser -Iprofiler -Iruntime -Iwtf -Iwtf/gobject -I/home/rmjzettl/Desktop/freecad_libs_source/qt-everywhere-opensource-src-4.8.0/src/3rdparty/webkit/Source/JavaScriptCore/wtf/symbian -Iwtf/unicode -Iyarr -IAPI -IForwardingHeaders -Igenerated -I../../Source -I../../include -I/include/QtWebKit -I/include -I.moc/release-static -o .obj/release-static/YarrInterpreter.o yarr/YarrInterpreter.cpp
    cc1plus: warnings being treated as errors
    ./wtf/PassOwnPtr.h: In instantiation of ‘WTF::PassOwnPtrJSC::Yarr::ByteDisjunction’:
    yarr/YarrInterpreter.h:328: instantiated from here
    ./wtf/PassOwnPtr.h:81: warning: lowering visibility of ‘WTF::PassOwnPtr<U> WTF::adoptPtr(U*) [with U = U, T = JSC::Yarr::ByteDisjunction]’ to match its type
    ./wtf/PassOwnPtr.h: In instantiation of ‘WTF::PassOwnPtrJSC::Yarr::BytecodePattern’:
    yarr/YarrInterpreter.cpp:1451: instantiated from here
    ./wtf/PassOwnPtr.h:81: warning: lowering visibility of ‘WTF::PassOwnPtr<U> WTF::adoptPtr(U*) [with U = U, T = JSC::Yarr::BytecodePattern]’ to match its type
    gmake[2]: *** [.obj/release-static/YarrInterpreter.o] Error 1
    gmake[2]: Leaving directory /home/rmjzettl/Desktop/freecad_libs_source/qt-everywhere-opensource-src-4.8.0/src/3rdparty/webkit/Source/JavaScriptCore' gmake[1]: *** [sub-JavaScriptCore-JavaScriptCore-pro-make_default-ordered] Error 2 gmake[1]: Leaving directory/home/rmjzettl/Desktop/freecad_libs_source/qt-everywhere-opensource-src-4.8.0/src/3rdparty/webkit/Source'
    gmake: *** [sub-webkit-make_default-ordered] Error 2

    The compiler I use
    gcc version 4.1.2 20080704 (Red Hat 4.1.2-50)

    As I need webkit, the -no-webkit configure switch is no option for me.

    I already searched for similar problems of other users but most others had the problem when doing some embedded target compilations.

    Hopefully you can find a solution for me as I need this to work pretty fast :-(

    Cheers and thank you in advance for any help.

    dvdjimmy



  • Hi again,

    after several tries I ended up in removing the CXXFLAG -Werror

    Now Webkit is compiling but I would like to know what kind of error I introduce! Any ideas? I absolutely have to make sure that I do not end up with runtime errors due to this removal.

    Cheers,
    dvdjimmy


  • Moderators

    welcome to devnet

    I have no experience with the linux distribution you are mentioning. The only thing I can tell you is that previous versions of Qt at least up to 4.7.2 generated lots of warnings. There would have been no way to compile virtually any of the modules with -Werror. I do not know for the webkit so.

    Based on that experience I would not get nervous by accepting the warning during the compilation. Those have been too numerous to track anyhow. I am wondering, if this has been really changed for version 4.8.

    Finally you need to have a look to the warnings and decide on an individual basis if they are acceptable or not.



  • Hi Koahnig,

    thx for your feedback. I did it now exactly as you proposed. Up to now, no runtime issues :-)

    Cheers,
    dvdjimmy


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.