Running executable in QT Creator vs command line



  • I created application that uses 3rd party dynamic libraries in QTCreator.

    I can run this application from command line, but when I run it from QT IDE I am getting an error that I don’t have permission to load third party library.

    Call to one of the library function creates process that needs to load additional library that is failed.

    I have the same error when run “Run” or “Start Debugging” commands in IDE.

    I am using Open SuSE Linux 11.4 and Qt Creator 2.1.0 (Qt 4.7.1).


  • Moderators

    Are you doing anything special on the command line to be able to run your application (special user, etc.)?

    Check the run settings (Projects->Run Settings), especially the environment there. Make sure you have the same settings as used on the command line.



  • Thanks for the hint.
    The command line invocation uses env variables (LD_LIBRARY_PATH in my case) and app found a library in /usr/bin64. QT Creator has different settings and used different version of the library for linking.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.