[SOLVED] Qt Creator & Qt in PATH & strange qmake location path



  • Hi,

    I have tried to make my own Qt applications for a while. Unfortunately most of time I have been problems with my Qt Environment in my PC without good understanding, how to set it to work smoothly.

    If said quickly the exact problem:
    Inside Qt Creator -> Tools -> Options -> Qt4 -> Qt Versions -> Auto-detected/Qt in PATH.

    I have in here strange path for 'qmake Location' -> c:\qt\2010.05\qt\bin\qmake.exe.
    Note: as you can see there is two backslaches and I don't known why. I can't remove that definition because these lines were colored with grey (i.e. can't edit).

    I have tried to solve out this problem to make my own Qt Version by Manually but it doesn't help either.

    I don't known why I can't use my own created Qt Version in Qt Creator under Projects view (icon on th left). I can't find these Qt Versions from there?

    Question: Does anyone known where is more accurate info related to this Topic? Any tips what is need to check e.g. from my environment settings etc.

    I would be very appreciated of any kind of help.



  • [quote author="MurPasten" date="1288488212"]
    I don't known why I can't use my own created Qt Version in Qt Creator under Projects view (icon on th left). I can't find these Qt Versions from there?[/quote]

    Hi,
    to use your own qt version try:

    Qt Creator -> Tools -> Options -> Qt4 -> Qt Versions ->

    click on the "plus" button to add a new version

    put the right path of the qmake located in your qt version's directory (for example: c:\myqtversion\bin\qmake)



  • Hey MurPasten,

    if you also want to use the Qt in your PATH you probably have to edit your PATH variable. There it probably says that your Qt installation is at c:\qt\2010.05\qt\bin\ but you should change that to c:\qt\2010.05\qt\bin without the last backslash.

    I don't know which version of Windows you are using. In Windows XP one had to right click on My Computer, chose Properties, go to the Advanced tab and there click on the environmental variables button. There you would have to change your PATH variable. I don't know though how you would do it on Vista or Win7.



  • Thanks Cyianor!

    Your advice really help to my strange Qt in PATH problem. Hard to believe that but now the problem is disappeared (i.e. just remove the last backslash :)

    I have W7 and the latest official Qt 4.7 (2010.05) and also NokiaQtSDK ..

    I believe this case is now closed.



  • Hey MurPasten,

    Great that it worked for you! You might consider editing your first post to put [solved] in front of the title of the thread so everybody knows you don't need help anymore and if somebody finds the thread, while looking for help, it's always more encouraging to open one with [solved] in front of it.

    Good luck and lots of fun checking out Qt!


  • Moderators

    MurPasten: Having several backslashes in a row should not matter. It should still work.

    Could you please file an issue in "our bugtracker":http://bugreports.qt.nokia.com if the two-backslash issue really broke qmake for you? Thanks!



  • Thanks for good advices.

    I had made a bug report behind that 'bugtracker', link for that (if needed): "http://bugreports.qt.nokia.com/browse/QTCREATORBUG-2990":http://bugreports.qt.nokia.com/browse/QTCREATORBUG-2990

    I verified this case again and that was really the reason to my problems that additional (the last) backslash in my environment settings.

    When that backslash was removed out --> then that 'Qt in PATH' was shown correctly.

    • wrong way: c:\qt\2010.05\qt\bin\
    • correct way: c:\qt\2010.05\qt\bin

    This case is now [SOLVED] :)



  • And thanks again Cyianor to you also :)


  • Moderators

    MurPasten: Is your issue that "Qt in PATH" did not work properly with c:\qt\2010.05\qt\bin\qmake.exe or does it only look strange?

    Could you please show me a screenshot of the details of Qt in PATH? Basically the same thing as you put in the bugreport, but after clicking on the "Qt in PATH" list so that I can see the Patch name, Qt Version name, etc. in the area below the list.

    Thanks!



  • Thanks Tobias,

    Additional picture has added into "the error report":http://bugreports.qt.nokia.com/browse/QTCREATORBUG-2990 -->

    And some answers to your question .. "does it only look strange" :)

    Yes, indeed. At first I have really supposed that my problems was related to the strange path in "Qt in PATH". But it seems that this is just a "cosmetic" issue but not 100% sure about that?

    I have just tried to figure out, how my personal Qt environment is need to configure successfully up so that I can create "fantastic" applications e.g. with QtMobility APIs. That's why I have two separate QtCreators in my PC and not always sure which one is need to use in my apps. But this is my personal problem and not a topic in here :)

    Hope that the picture was the right thing what you want..

    [mark up link, Tobias Hunger]


  • Moderators

    As you might have noticed: The cosmetic issue is resolved in master, but unfortunately not in the 2.1 branch where we released a beta of today.

    I just wanted to make sure we did not have some additional problem lurking somewhere:-)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.